summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:36 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:50 +0100
commitf4f5fca49ca36553e2eb0c06df26f26db11df418 (patch)
treea422150331b077715afbe22bd8aa72f71db1b7a5 /gnu/packages/haskell-xyz.scm
parentc62fdba44d3a41fcdd09dde4282661296b6997ca (diff)
downloadguix-patches-f4f5fca49ca36553e2eb0c06df26f26db11df418.tar
guix-patches-f4f5fca49ca36553e2eb0c06df26f26db11df418.tar.gz
gnu: ghc-hslua: Update to 1.3.0.2.
* gnu/packages/haskell-xyz.scm (ghc-hslua): Update to 1.3.0.2. [inputs]: Remove ghc-exceptions and ghc-fail; add ghc-base-compat. [native-inputs]: Remove ghc-tasty-expected-failure; add ghc-fail and ghc-semigroups.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e80f20b0d0..f166969de1 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6197,29 +6197,29 @@ handler built in.")
(define-public ghc-hslua
(package
(name "ghc-hslua")
- (version "1.3.0.1")
+ (version "1.3.0.2")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"hslua/hslua-" version ".tar.gz"))
(sha256
(base32
- "1mz8zk13dhgaf24hmmjqnn5hcln96iw73mcjwjilag8388wq72k7"))))
+ "0p39xm0mmxzs5x6aim11qkb7npn0d9h7li2kwfhry0dijd1vm18i"))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags '("-fsystem-lua")
#:extra-directories ("lua")))
(inputs
`(("lua" ,lua)
- ("ghc-exceptions" ,ghc-exceptions)
- ("ghc-fail" ,ghc-fail)))
+ ("ghc-base-compat" ,ghc-base-compat)))
(native-inputs
`(("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-expected-failure" ,ghc-tasty-expected-failure)
("ghc-tasty-hunit" ,ghc-tasty-hunit)
("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
("ghc-quickcheck" ,ghc-quickcheck)
- ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)))
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
+ ("ghc-fail" ,ghc-fail)
+ ("ghc-semigroups" ,ghc-semigroups)))
(home-page "https://hackage.haskell.org/package/hslua")
(synopsis "Lua language interpreter embedding in Haskell")
(description