summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorCarlo Holl <carloholl@gmail.com>2020-11-25 12:16:34 -0800
committerLeo Famulari <leo@famulari.name>2020-11-25 21:02:16 -0500
commitdf0e411373298e464dd6971129de01316cfa168c (patch)
treea109bdf690f6f38512c91a6a8a1b6485ea11cc06 /gnu/packages/haskell-xyz.scm
parent4e3b6235a427f3c278f65a0313da1d21b53232b7 (diff)
downloadguix-patches-df0e411373298e464dd6971129de01316cfa168c.tar
guix-patches-df0e411373298e464dd6971129de01316cfa168c.tar.gz
gnu: ghc-doctest: Downgrade to 0.16.2.
* gnu/packages/haskell-xyz.scm (ghc-doctest): Downgrade to 0.16.2. [inputs]: Replace with what is generated by guix import. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7f68b82fc1..67395baea3 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3551,7 +3551,7 @@ Writer monad), where list append quickly becomes too expensive.")
(define-public ghc-doctest
(package
(name "ghc-doctest")
- (version "0.16.3")
+ (version "0.16.2")
(source
(origin
(method url-fetch)
@@ -3561,7 +3561,7 @@ Writer monad), where list append quickly becomes too expensive.")
".tar.gz"))
(sha256
(base32
- "1y1l7aa80qkib1z8lsizgg7fpfdmdwhxvi5m255a42jdkjgn5sfg"))))
+ "0lk4cjfzi5bx2snfzw1zi06li0gvgz3ckfh2kwa98l7nxfdl39ag"))))
(build-system haskell-build-system)
(arguments `(#:tests? #f)) ; FIXME: missing test framework
(inputs
@@ -3573,7 +3573,6 @@ Writer monad), where list append quickly becomes too expensive.")
`(("ghc-hunit" ,ghc-hunit)
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-hspec" ,ghc-hspec)
- ("ghc-hspec-core" ,ghc-hspec-core)
("ghc-mockery" ,ghc-mockery)
("ghc-setenv" ,ghc-setenv)
("ghc-silently" ,ghc-silently)