summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-01 15:37:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-01 15:39:33 +0100
commitace3af2b8026044cc05afb8d14cf333c51fbbd35 (patch)
treeea6f398c6afe4021b41e98fc03e0b9a8ef63ee62 /gnu/packages/haskell-xyz.scm
parentc16628ea6e7a37cd324a40637074311473d9f3b2 (diff)
downloadguix-patches-ace3af2b8026044cc05afb8d14cf333c51fbbd35.tar
guix-patches-ace3af2b8026044cc05afb8d14cf333c51fbbd35.tar.gz
gnu: pandoc-citeproc: Separate outputs.
This removes unnecessary references to Haskell packages for the statically built executable. * gnu/packages/haskell-xyz.scm (pandoc-citeproc)[outputs]: Add "lib" and "doc" outputs.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7f443dab3d..d6c50ade71 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9581,6 +9581,7 @@ getDataFileName name = do
("pandoc" ,pandoc "lib")
,@all-static-inputs
,@direct-inputs)))
+ (outputs '("out" "lib" "static" "doc"))
(synopsis "Pandoc filter for bibliographic references")))
(define-public ghc-pandoc-types