summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-27 22:30:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-13 16:44:58 +0200
commitc7891956cdccfb5ecd2c4770e9b7e04bcff5d861 (patch)
tree2f58990a54c00b3f5d14b4df19cd2e9c553b174b /gnu/packages/haskell-xyz.scm
parent78215a14b1a3728f6702a5673d18194b5b370757 (diff)
downloadguix-patches-c7891956cdccfb5ecd2c4770e9b7e04bcff5d861.tar
guix-patches-c7891956cdccfb5ecd2c4770e9b7e04bcff5d861.tar.gz
gnu: ghc-pandoc-types: Avoid embedding spurious references.
* gnu/packages/haskell-xyz.scm (ghc-pandoc-types)[arguments]: Add build phase "create-simple-paths-module" to prevent retaining unnecessary references.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3503b783d7..3cf6a9f02b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8896,6 +8896,26 @@ suitable for inclusion in pandoc YAML metadata.")
(base32
"1d6ygq991ddria71l7hg9yd7lq94sjy4m71rdws1v8hq943c4d0q"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; None of the directory names are actually used. By generating a
+ ;; simpler module without references to store names we avoid
+ ;; introducing references in the pandoc executable.
+ (add-after 'unpack 'create-simple-paths-module
+ (lambda _
+ (call-with-output-file "Paths_pandoc_types.hs"
+ (lambda (port)
+ (format port "\
+{-# LANGUAGE CPP #-}
+{-# LANGUAGE NoRebindableSyntax #-}
+{-# OPTIONS_GHC -fno-warn-missing-import-lists #-}
+module Paths_pandoc_types (version) where
+import Data.Version (Version(..))
+version :: Version
+version = Version [~a] []
+" (string-map (lambda (chr) (if (eq? chr #\.) #\, chr)) ,version))))
+ #t)))))
(inputs
`(("ghc-syb" ,ghc-syb)
("ghc-aeson" ,ghc-aeson)