summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-07-07 17:32:28 -0700
committerTimothy Sample <samplet@ngyro.com>2019-09-02 23:09:38 -0400
commit7bbfa3926e48e366126f6500e3d7ef1097c4ffcb (patch)
treef88ecf77b74eb6cee20b9b153b9232309898cde4 /gnu/packages/haskell-xyz.scm
parent6b652f5af3ddf9d8d894d1270441ab29354cca97 (diff)
downloadguix-patches-7bbfa3926e48e366126f6500e3d7ef1097c4ffcb.tar
guix-patches-7bbfa3926e48e366126f6500e3d7ef1097c4ffcb.tar.gz
gnu: Add ghc-timeit.
* gnu/packages/haskell-xyz.scm (ghc-timeit): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 2dbafe6770..b2cee24471 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10108,6 +10108,27 @@ function which generates instances.")
@code{TimeLocale}.")
(license license:bsd-3)))
+(define-public ghc-timeit
+ (package
+ (name "ghc-timeit")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://hackage.haskell.org/package/timeit/timeit-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1sliqpvl501rlcj6s0lhmsf5ym24j4h881wzc1f1wdyvg3jz8kd1"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/merijn/timeit")
+ (synopsis "Time monadic computations with an IO base")
+ (description "This package provides a simple wrapper to show the
+used CPU time of monadic computation with an IO base.")
+ (license license:bsd-3)))
+
(define-public ghc-tldr
(package
(name "ghc-tldr")