summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:38 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:52 +0100
commit8614121bdf6a8235aff1c7294cd74d309805650e (patch)
tree600e08cb2b2497c63246879e64afd4693057bb1e /gnu/packages/haskell-xyz.scm
parent546d057833954e2cfbe6d526f1a6a0cbe89fbc2d (diff)
downloadguix-patches-8614121bdf6a8235aff1c7294cd74d309805650e.tar
guix-patches-8614121bdf6a8235aff1c7294cd74d309805650e.tar.gz
gnu: ghc-pandoc-types: Update to 1.22.1.
* gnu/packages/haskell-xyz.scm (ghc-pandoc-types): Update to 1.22.1. [inputs]: Remove ghc-string-qq. [native-inputs]: Add ghc-string-qq.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 83f2568f72..491c3dc9b1 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9514,7 +9514,7 @@ getDataFileName name = do
(define-public ghc-pandoc-types
(package
(name "ghc-pandoc-types")
- (version "1.22")
+ (version "1.22.1")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -9522,7 +9522,7 @@ getDataFileName name = do
version ".tar.gz"))
(sha256
(base32
- "0kr5n9yw59513pw2rjc65qs55iq0prn16prk4781arqdh7g7a09q"))))
+ "0z2j306jsiriwhib0201hsllwyck7qcvqci5c25frwsmknr3mls2"))))
(build-system haskell-build-system)
(arguments
`(#:phases
@@ -9546,13 +9546,13 @@ version = Version [~a] []
#t)))))
(inputs
`(("ghc-syb" ,ghc-syb)
- ("ghc-aeson" ,ghc-aeson)
- ("ghc-string-qq" ,ghc-string-qq)))
+ ("ghc-aeson" ,ghc-aeson)))
(native-inputs
`(("ghc-quickcheck" ,ghc-quickcheck)
("ghc-test-framework" ,ghc-test-framework)
("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-string-qq" ,ghc-string-qq)
("ghc-hunit" ,ghc-hunit)))
(home-page "https://pandoc.org")
(synopsis "Types for representing a structured document")