summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-05 15:34:26 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:54 +0200
commitd142843d150bf874bda2028262c7a6ebcef95b73 (patch)
tree0dd66444fb8200c00f0953155145967b08865239 /gnu/packages/haskell-xyz.scm
parent06587abbd2e6b94d8afae279dbe4f480617a063f (diff)
downloadguix-patches-d142843d150bf874bda2028262c7a6ebcef95b73.tar
guix-patches-d142843d150bf874bda2028262c7a6ebcef95b73.tar.gz
gnu: ghc-repline: Remove version 0.2.0.0.
Not required by any package in the tree. * gnu/packages/haskell-xyz.scm (ghc-repline-0.3): Merge into… (ghc-repline): …this. * gnu/packages/dhall.scm (dhall): Use ghc-repline.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm27
1 files changed, 6 insertions, 21 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 06b086c276..7445e47a71 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11092,18 +11092,21 @@ inspired by libtre.")
(define-public ghc-repline
(package
(name "ghc-repline")
- (version "0.2.0.0")
+ (version "0.4.0.0")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://hackage/package/repline/repline-"
+ "https://hackage.haskell.org/package/repline/repline-"
version
".tar.gz"))
(sha256
(base32
- "1ph21kbbanlcs8n5lwk16g9vqkb98mkbz5mzwrp8j2rls2921izc"))))
+ "1dspwi28krinkxdd7waq4y6plz0dfmzz72885p9pcqp1r14qrhj3"))))
(build-system haskell-build-system)
+ (inputs
+ `(("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-haskeline" ,ghc-haskeline-0.8)))
(home-page "https://github.com/sdiehl/repline")
(synopsis "Haskeline wrapper for GHCi-like REPL interfaces")
(description
@@ -11111,24 +11114,6 @@ inspired by libtre.")
normal mtl transformers.")
(license license:expat)))
-(define-public ghc-repline-0.3
- (package
- (inherit ghc-repline)
- (version "0.4.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/repline/repline-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "1dspwi28krinkxdd7waq4y6plz0dfmzz72885p9pcqp1r14qrhj3"))))
- (inputs
- `(("ghc-exceptions" ,ghc-exceptions)
- ("ghc-haskeline" ,ghc-haskeline-0.8)))))
-
(define-public ghc-rerebase
(package
(name "ghc-rerebase")