summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 21:14:06 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:32 -0500
commitb9debc37b80df414925e1b0438b3c0377f3d3b1b (patch)
treec7287a83a4d25ee8e21ec74830064d63fcb7040d /gnu/packages/haskell-xyz.scm
parent803e6780968967d9624ecbda794d7a7410e6f69c (diff)
downloadguix-patches-b9debc37b80df414925e1b0438b3c0377f3d3b1b.tar
guix-patches-b9debc37b80df414925e1b0438b3c0377f3d3b1b.tar.gz
gnu: Add ghc-retry.
* gnu/packages/haskell-xyz.scm (ghc-retry): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7b1c4756fb..d5ce5400ee 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8635,6 +8635,40 @@ connections.")
code where you can safely allocate resources.")
(license license:bsd-3)))
+(define-public ghc-retry
+ (package
+ (name "ghc-retry")
+ (version "0.8.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "retry/retry-" version ".tar.gz"))
+ (sha256
+ (base32
+ "02k03r86amg1vbrsvb644342ym13d9jwkzki9sk93pdg5l8j35dj"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-random" ,ghc-random)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-hedgehog" ,ghc-tasty-hedgehog)
+ ("ghc-hedgehog" ,ghc-hedgehog)))
+ (home-page "http://github.com/Soostone/retry")
+ (synopsis "Retry combinators for monadic actions that may fail")
+ (description "This package exposes combinators that can wrap
+arbitrary monadic actions. They run the action and potentially retry
+running it with some configurable delay for a configurable number of
+times. The purpose is to make it easier to work with IO and especially
+network IO actions that often experience temporary failure and warrant
+retrying of the original action. For example, a database query may time
+out for a while, in which case we should hang back for a bit and retry
+the query instead of simply raising an exception.")
+ (license license:bsd-3)))
+
(define-public ghc-rfc5051
(package
(name "ghc-rfc5051")