summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-05 14:46:35 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:40 -0500
commit87309478b3944a90f8bbef296c6d30c3ec0e9269 (patch)
tree0bf6a3681691a611af7465989cf4f9f008edc34b /gnu/packages/haskell-xyz.scm
parent034380f3146916fbce972eec3f9f7707db9ca93d (diff)
downloadguix-patches-87309478b3944a90f8bbef296c6d30c3ec0e9269.tar
guix-patches-87309478b3944a90f8bbef296c6d30c3ec0e9269.tar.gz
gnu: ghc-resolv: Update to 0.1.1.2.
* gnu/packages/haskell-xyz.scm (ghc-resolv): Update to 0.1.1.2. [arguments]: Remove '#:cabal-revision', enable tests, and add a phase to update the Cabal file to allow newer versions of 'tasty'. [native-inputs]: Add 'ghc-tasty' and 'ghc-tasty-hunit'.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3bab36acb1..afbbb0a9de 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8641,7 +8641,7 @@ the project's home page}.")
(define-public ghc-resolv
(package
(name "ghc-resolv")
- (version "0.1.1.1")
+ (version "0.1.1.2")
(source
(origin
(method url-fetch)
@@ -8650,14 +8650,22 @@ the project's home page}.")
version ".tar.gz"))
(sha256
(base32
- "0wh7wj56l3f2bylz563g5g04a4nydj8acv60hpwa7k3mn792xca9"))))
+ "0wczdy3vmpfcfwjn1m95bygc5d83m97xxmavhdvy5ayn8c402fp4"))))
(build-system haskell-build-system)
(arguments
- `(#:cabal-revision
- ("1" "15ay4n3x8c09cb3h4z1nan84yd3n9zpgvi6h114hk98bq10k8mma")
- #:tests? #f)) ; The required test frameworks are too old.
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "resolv.cabal"
+ (("tasty >= 1\\.1 && < 1\\.2")
+ "tasty >= 1.1 && < 1.3"))
+ #t)))))
(inputs
`(("ghc-base16-bytestring" ,ghc-base16-bytestring)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
(home-page "https://github.com/haskell/hackage-security")
(synopsis "Domain Name Service (DNS) lookup via @code{libresolv}")
(description "This package implements an API for accessing the