summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-05 14:03:40 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:38 -0500
commit1f656b17d9c5d148f07e01d28044d84ba3a91679 (patch)
treebb28d8ee490d333991e3f81ed64d14279cc0d59d /gnu/packages/haskell-xyz.scm
parentbdc877c4d273bbb6ee0d21cdceb3ff36804a076c (diff)
downloadguix-patches-1f656b17d9c5d148f07e01d28044d84ba3a91679.tar
guix-patches-1f656b17d9c5d148f07e01d28044d84ba3a91679.tar.gz
gnu: Add ghc-infer-license.
* gnu/packages/haskell-xyz.scm (ghc-infer-license): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 46bf1e53c8..e0aa5ee23a 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5208,6 +5208,30 @@ contexts. It parses blocks of lines all indented to the same level as well as
lines continued at an indented level below.")
(license license:bsd-3)))
+(define-public ghc-infer-license
+ (package
+ (name "ghc-infer-license")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "infer-license/infer-license-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wlfm6bf55kfvm74xar9lmjg5v1103rs9m3grw1rq5bmcmhzxrhj"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-text-metrics" ,ghc-text-metrics)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "http://hackage.haskell.org/package/infer-license")
+ (synopsis "Infer software license from a given license file")
+ (description "This library provides tools to infer a software
+license from a given license file.")
+ (license license:expat)))
+
(define-public ghc-inline-c
(package
(name "ghc-inline-c")