summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:25:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:11 +0200
commitf1ac3bba6648484b096a6792940e0e2c55b151e0 (patch)
tree896e6a3d55d81747c8b2a4be6c05cec26dbe35b5 /gnu/packages/haskell-check.scm
parente42e9024c1528deca9daa86482ac1a5c322e5cd2 (diff)
downloadguix-patches-f1ac3bba6648484b096a6792940e0e2c55b151e0.tar
guix-patches-f1ac3bba6648484b096a6792940e0e2c55b151e0.tar.gz
gnu: ghc-hunit: Update to 1.6.0.0.
* gnu/packages/haskell-check.scm (ghc-hunit): Update to 1.6.0.0. [inputs]: Add ghc-call-stack-boot.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index d6b171d5b3..b2d352050f 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -603,19 +603,21 @@ using Template Haskell")
(define-public ghc-hunit
(package
(name "ghc-hunit")
- (version "1.3.1.2")
+ (version "1.6.0.0")
(outputs '("out" "doc"))
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/HUnit/HUnit-"
- version
- ".tar.gz"))
+ (uri (string-append "https://hackage.haskell.org/package/HUnit/"
+ "HUnit-" version ".tar.gz"))
(sha256
(base32
- "10akdh4fl615rrshxi3m5gf414il1q42z4zqyb6q4jasmscvzpms"))))
+ "1pnhwqq5v8h48gbp3ibv3skfj25mf4zs5svxcavq93p9cswycj3l"))))
(build-system haskell-build-system)
+ (inputs
+ ;; We cannot use ghc-call-stack there, because it depends on
+ ;; ghc-nanospec, which depends on ghc-hunit.
+ `(("ghc-call-stack" ,ghc-call-stack-boot)))
(home-page "http://hunit.sourceforge.net/")
(synopsis "Unit testing framework for Haskell")
(description