summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-11 14:34:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-11 14:35:24 +0300
commit5de2246f408743c1a253e0fa7dfe902ec2a05355 (patch)
treec83798fefd86e71f134f2299e28bb1b11e5a4d3e /gnu/packages/haskell-apps.scm
parent232f2d2634074201967a47935aa80665cc5e6bbe (diff)
downloadguix-patches-5de2246f408743c1a253e0fa7dfe902ec2a05355.tar
guix-patches-5de2246f408743c1a253e0fa7dfe902ec2a05355.tar.gz
gnu: git-annex: Add support for v4 of S3 support.
* gnu/packages/haskell-apps.scm (git-annex)[source]: Add patch. * gnu/packages/patches/git-annex-S3v4.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 4785ebaca3..13c8bbcf89 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015 John Soo <jsoo1@asu.edu>
-;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
@@ -37,6 +37,7 @@
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system haskell)
+ #:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages curl)
#:use-module (gnu packages gl)
@@ -347,6 +348,7 @@ to @code{cabal repl}).")
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"git-annex/git-annex-" version ".tar.gz"))
+ (patches (search-patches "git-annex-S3v4.patch"))
(sha256
(base32 "19rggaymvqy7r61n2rl2nigwdi2hzq5l1afcd5l0k1vbacwgq4jl"))))
(build-system haskell-build-system)