summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2022-11-29 01:09:03 +0000
committerEfraim Flashner <efraim@flashner.co.il>2022-12-01 10:46:15 +0200
commitf726d2fd0708395bbe70b97cd724f86a21055524 (patch)
tree2c508552fc4004eaba5c4cdcc46bef9a5690ea7b /gnu/packages/hardware.scm
parent42325fc37370686a6b153632cf794a095e791f7a (diff)
downloadguix-patches-f726d2fd0708395bbe70b97cd724f86a21055524.tar
guix-patches-f726d2fd0708395bbe70b97cd724f86a21055524.tar.gz
gnu: openrgb: Update to 0.8.
* gnu/packages/hardware.scm (openrgb): Update to 0.8. [native-inputs]: Add qttools-5 for generating translations. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index f392bb8c16..9da2b4ad29 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -998,7 +998,7 @@ technology, such as head mounted displays with built in head tracking.")
(define-public openrgb
(package
(name "openrgb")
- (version "0.7")
+ (version "0.8")
(source
(origin
(method git-fetch)
@@ -1007,7 +1007,7 @@ technology, such as head mounted displays with built in head tracking.")
(commit (string-append "release_" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0xhfaz0b74nfnh7il2cz5c0338xlzay00g6hc2h3lsncarj8d5n7"))
+ (base32 "1yz7sdrjcxajm1zpa5djinmych5dvck0r1fvk0x5qmk87va4p9z3"))
(patches
(search-patches "openrgb-unbundle-hueplusplus.patch"))
(modules '((guix build utils)))
@@ -1044,7 +1044,8 @@ technology, such as head mounted displays with built in head tracking.")
mbedtls-apache
qtbase-5))
(native-inputs
- (list pkg-config))
+ (list pkg-config
+ qttools-5))
(synopsis "RGB lighting control")
(description
"OpenRGB is lighting control that doesn't depend on manufacturer software.