summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-03-28 15:35:56 +0200
committerLudovic Courtès <ludo@gnu.org>2023-03-30 12:44:21 +0200
commit14cd517e0cb8829b06b5a49f91c762c4a0e52eb5 (patch)
tree1a840adc595d9ac8b76847ba4f364978f06b523c /gnu/packages/guile.scm
parent0b2d1fd41096cb394064bfa3e599c7024904ec97 (diff)
downloadguix-patches-14cd517e0cb8829b06b5a49f91c762c4a0e52eb5.tar
guix-patches-14cd517e0cb8829b06b5a49f91c762c4a0e52eb5.tar.gz
gnu: guile: Fix 'posix_spawn' usage for GNU/Hurd.
* gnu/packages/guile.scm (guile-3.0)[arguments]: Add 'patch-posix-spawn-usage' phase. * gnu/packages/patches/guile-hurd-posix-spawn.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 8e52448d36..8d25614e3a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -371,6 +371,16 @@ without requiring the source code to be rewritten.")
(("!#")
"!#\n(exit 77)\n"))))
+ #$@(if (target-hurd?)
+ #~((add-before 'build 'patch-posix-spawn-usage
+ (lambda _
+ ;; TODO: Move patch to 'source' on next rebuild
+ ;; cycle.
+ (define patch
+ #$(local-file
+ (search-patch "guile-hurd-posix-spawn.patch")))
+ (invoke "patch" "--force" "-p1" "-i" patch))))
+ #~())
#$@(if (target-ppc32?)
#~((add-after 'unpack 'adjust-bootstrap-flags
(lambda _