summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-01-23 15:49:02 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-23 23:47:02 +0100
commit2ea52f90141974fb5d88b8c6b1785817c4203da4 (patch)
treea3ce3e303929999d304270674c9510be92b22e9e /gnu/packages/guile.scm
parentab62cbb340aa943c56ff01da93220b3212f714dd (diff)
downloadguix-patches-2ea52f90141974fb5d88b8c6b1785817c4203da4.tar
guix-patches-2ea52f90141974fb5d88b8c6b1785817c4203da4.tar.gz
gnu: guile: Disable parallel builds.
This works around <https://bugs.gnu.org/20272>, as discussed in <https://lists.gnu.org/archive/html/guix-devel/2021-01/msg00273.html>. * gnu/packages/guile.scm (guile-2.0)[arguments]: Pass #:parallel-build? #f.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 878857fe29..691cb363c2 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2016, 2018 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2017, 2018 Mark H Weaver <mhw@netris.org>
@@ -179,6 +179,11 @@ without requiring the source code to be rewritten.")
(arguments
`(#:configure-flags '("--disable-static") ; saves 3 MiB
+
+ ;; Work around non-reproducible .go files as described in
+ ;; <https://bugs.gnu.org/20272>, which affects 2.0, 2.2, and 3.0 so far.
+ #:parallel-build? #f
+
#:phases
(modify-phases %standard-phases
,@(if (hurd-system?)