summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-01-25 17:07:21 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-25 17:07:21 +0100
commit200a97e64f29dc904961e99bcbc0f20fef431dd2 (patch)
tree4b8d5c809925320e74efb8c9657037ee6f00d718 /gnu/packages/guile.scm
parentfcaa7523d4f37d5b3c4bf459784e826f98252fe8 (diff)
parent1909431c5b6413c496eb93d3d74be3e3e936951b (diff)
downloadguix-patches-200a97e64f29dc904961e99bcbc0f20fef431dd2.tar
guix-patches-200a97e64f29dc904961e99bcbc0f20fef431dd2.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 3dbb5d8429..29ec1096dc 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,7 +35,9 @@
#:use-module (gnu packages which)
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (guix utils)
+ #:use-module (ice-9 match))
;;; Commentary:
;;;
@@ -134,7 +136,7 @@ without requiring the source code to be rewritten.")
;; The headers and/or `guile-2.0.pc' refer to these packages, so they
;; must be propagated.
- ("bdw-gc" ,libgc)
+ ("bdw-gc" ,libgc-7.4)
("gmp" ,gmp)))
(self-native-input? #t)
@@ -173,7 +175,15 @@ without requiring the source code to be rewritten.")
(define-public guile-2.0/fixed
;; A package of Guile 2.0 that's rarely changed. It is the one used
;; in the `base' module, and thus changing it entails a full rebuild.
- guile-2.0)
+ (package (inherit guile-2.0)
+ (location (source-properties->location (current-source-location)))
+
+ ;; Keep using the stable libgc.
+ (propagated-inputs (map (match-lambda
+ (("bdw-gc" _)
+ `("bdw-gc" ,libgc))
+ (x x))
+ (package-propagated-inputs guile-2.0)))))
;;;