summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-27 23:19:49 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-27 23:19:49 +0200
commitaf018f5e0a1b7c67e9f40ca68929bd35b94206d3 (patch)
tree8c3efe66f8ac1f6178357937c0a41c6f5ff8f0f8 /gnu/packages/guile.scm
parentd84a7be6675bd647931d8eff9134d00dd5a6bd58 (diff)
parent35066aa596931ef84922298c2760ceba69940cd1 (diff)
downloadguix-patches-af018f5e0a1b7c67e9f40ca68929bd35b94206d3.tar
guix-patches-af018f5e0a1b7c67e9f40ca68929bd35b94206d3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index a240937f75..4c42d82345 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -247,7 +247,8 @@ many readers as needed).")
(inputs `(("ncurses" ,ncurses)
("guile" ,guile-2.0)))
(arguments
- '(#:configure-flags (list (string-append "--with-guilesitedir="
+ '(#:configure-flags (list "--with-ncursesw" ; Unicode support
+ (string-append "--with-guilesitedir="
(assoc-ref %outputs "out")
"/share/guile/site/2.0"))
#:phases (alist-cons-after
@@ -271,18 +272,18 @@ library.")
(define-public mcron
(package
(name "mcron")
- (version "1.0.6")
+ (version "1.0.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mcron/mcron-"
version ".tar.gz"))
(sha256
(base32
- "0yvrfzzdy2m7fbqkr61fw01wd9r2jpnbyabxhcsfivgxywknl0fy"))
+ "1d214fmhsn3kvpnwxnqwfpy6gr5c5dbz2mx3sijhxi070vkfibxc"))
(patches (list (search-patch "mcron-install.patch")))))
(build-system gnu-build-system)
- (inputs
- `(("ed" ,ed) ("which" ,which) ("guile" ,guile-1.8)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("ed" ,ed) ("which" ,which) ("guile" ,guile-2.0)))
(home-page "http://www.gnu.org/software/mcron/")
(synopsis "Run jobs at scheduled times")
(description