summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-06 10:37:52 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-06 10:37:52 +0200
commit234ea3d65330af4c62b086419f23343433cd58c3 (patch)
tree79f9a92ff5cfb65c7fd0817927b0551d89b1d6c6 /gnu/packages/guile.scm
parent5ea69d9a563fa1e2890c94fe9574c7e16f778f3b (diff)
downloadguix-patches-234ea3d65330af4c62b086419f23343433cd58c3.tar
guix-patches-234ea3d65330af4c62b086419f23343433cd58c3.tar.gz
gnu: guile-aspell: Update to 0.4.
* gnu/packages/guile.scm (guile-aspell): Update to 0.4. [arguments] <#:phases>: Adjust 'set-libaspell-file-name' to new source tree layout.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 96fc84a960..99b2ca1180 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1520,7 +1520,7 @@ type system, elevating types to first-class status.")
(define-public guile-aspell
(package
(name "guile-aspell")
- (version "0.3")
+ (version "0.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1528,7 +1528,7 @@ type system, elevating types to first-class status.")
version ".tar.gz"))
(sha256
(base32
- "1wknn57x2qcsbn7zw6sbn1ma6fjsg8cvpnf78ak47s8jw6k6j75n"))))
+ "0vpk5xj9m9qc702z3khmkwhgpb949qbsyz8kw2qycda6qnxk0077"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list (string-append "--with-guilesitedir="
@@ -1538,7 +1538,7 @@ type system, elevating types to first-class status.")
(add-before 'build 'set-libaspell-file-name
(lambda* (#:key inputs #:allow-other-keys)
(let ((aspell (assoc-ref inputs "aspell")))
- (substitute* "aspell/aspell.scm"
+ (substitute* "aspell.scm"
(("\"libaspell\\.so\"")
(string-append "\"" aspell
"/lib/libaspell\"")))