summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-07-27 15:02:33 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-07-27 15:02:33 +0200
commite5758aeb0e2716193a4b8b8233e54dafcfd1d8c8 (patch)
treeb6d0f97305920b8da3038e9cf360b83ec8556c4c /gnu/packages/guile.scm
parentbc76f8b1f9a74c0f187022991b633cc1820944c7 (diff)
downloadguix-patches-e5758aeb0e2716193a4b8b8233e54dafcfd1d8c8.tar
guix-patches-e5758aeb0e2716193a4b8b8233e54dafcfd1d8c8.tar.gz
gnu: Move guile-zlib and guile-lzlib packages.
* gnu/packages/guile-xyz.scm (guile-zlib, guile-lzlib): Move to ... * gnu/packages/guile.scm: ... here.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm67
1 files changed, 66 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6430633694..b2670eca7d 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -777,5 +777,70 @@ manipulate repositories of the Git version control system.")
(define-deprecated-guile3.0-package guile3.0-git)
-;;; guile.scm ends here
+(define-public guile-zlib
+ (package
+ (name "guile-zlib")
+ (version "0.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/guile-zlib/guile-zlib.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "139ixlg0663azwpcj24sw27kmzxr5am0j6hn62ffjchi9w1qb3k0"))
+ (modules '((guix build utils)))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags
+ '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-3.0)
+ ("zlib" ,zlib)))
+ (synopsis "Guile bindings to zlib")
+ (description
+ "This package provides Guile bindings for zlib, a lossless
+data-compression library. The bindings are written in pure Scheme by using
+Guile's foreign function interface.")
+ (home-page "https://notabug.org/guile-zlib/guile-zlib")
+ (license license:gpl3+)))
+(define-public guile-lzlib
+ (package
+ (name "guile-lzlib")
+ (version "0.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/guile-lzlib/guile-lzlib.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ny4pbig5x1lv83b63c2613gwv98myk3rm44l88ic7lrff6cd2hr"))
+ (modules '((guix build utils)))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags
+ '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-3.0)
+ ("lzlib" ,lzlib)))
+ (synopsis "Guile bindings to lzlib")
+ (description
+ "This package provides Guile bindings for lzlib, a C library for
+in-memory LZMA compression and decompression. The bindings are written in
+pure Scheme by using Guile's foreign function interface.")
+ (home-page "https://notabug.org/guile-lzlib/guile-lzlib")
+ (license license:gpl3+)))
+
+;;; guile.scm ends here