summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-04 23:52:52 -0400
committerMark H Weaver <mhw@netris.org>2016-08-20 21:46:31 -0400
commit7f9c897098cc18c06c7f6c9d2f1a675a5a4fb7f9 (patch)
tree2d8ca3f6f510c341b00171e6b7029f9601702fbb /gnu/packages/guile.scm
parent1063d325ea76aa2b00dfcd3d436b16e412103df1 (diff)
downloadguix-patches-7f9c897098cc18c06c7f6c9d2f1a675a5a4fb7f9.tar
guix-patches-7f9c897098cc18c06c7f6c9d2f1a675a5a4fb7f9.tar.gz
gnu: guile-2.0: Update to 2.0.12.
* gnu/packages/guile.scm (guile-2.0): Update to 2.0.12. (guile-2.0/fixed): Keep at 2.0.11. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index c28ec87126..ac364fd15a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -130,14 +130,14 @@ without requiring the source code to be rewritten.")
(define-public guile-2.0
(package
(name "guile")
- (version "2.0.11")
+ (version "2.0.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/guile/guile-" version
".tar.xz"))
(sha256
(base32
- "1qh3j7308qvsjgwf7h94yqgckpbgz2k3yqdkzsyhqcafvfka9l5f"))
+ "1sdpjq0jf1h65w29q0zprj4x6kdp5jskkvbnlwphy9lvdxrqg0fy"))
(patches (search-patches "guile-arm-fixes.patch"))))
(build-system gnu-build-system)
(native-inputs `(("pkgconfig" ,pkg-config)))
@@ -199,7 +199,17 @@ without requiring the source code to be rewritten.")
(define-public guile-2.0/fixed
;; A package of Guile 2.0 that's rarely changed. It is the one used
;; in the `base' module, and thus changing it entails a full rebuild.
- guile-2.0)
+ (package
+ (inherit guile-2.0)
+ (version "2.0.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/guile/guile-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "1qh3j7308qvsjgwf7h94yqgckpbgz2k3yqdkzsyhqcafvfka9l5f"))
+ (patches (search-patches "guile-arm-fixes.patch"))))))
(define-public guile-next
(package (inherit guile-2.0)