summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-19 20:15:57 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-19 20:15:57 +0200
commitf62efeff76021d205d081aaf68034a234195ae0f (patch)
tree934f969584794fba16a20b36916a8c8fd7f79fd7 /gnu/packages/guile-xyz.scm
parent4eca7833ef0b16fb3cdda138e3ee1e5824c36e41 (diff)
parentb6b8e5004de56a55186b215b3263b39f34e8ce1d (diff)
downloadguix-patches-f62efeff76021d205d081aaf68034a234195ae0f.tar
guix-patches-f62efeff76021d205d081aaf68034a234195ae0f.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm70
1 files changed, 33 insertions, 37 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 854ea6eae0..51ae8df906 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1054,36 +1054,33 @@ It has a nice, simple s-expression based syntax.")
(inputs (list guile-2.2))))
(define-public guile-scheme-json-rpc
- (let ((commit "45ae6890f6619286f5679f88c094c88127b54c4a")
- (revision "0")
- (version "0.2.11"))
- (package
- (name "guile-scheme-json-rpc")
- (version (git-version version revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/rgherdt/scheme-json-rpc.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0w4m8xx8yyj0rv0q57mjr8ja87l7yikscj33i3ck26wg7230ppa5"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'change-to-guile-dir
- (lambda _
- (chdir "guile"))))))
- (inputs (list guile-3.0 guile-json-3))
- (native-inputs (list pkg-config))
- (synopsis "Library providing JSON-RPC capability in Scheme")
- (description
- "This library implements parts of the
+ (package
+ (name "guile-scheme-json-rpc")
+ (version "0.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/rgherdt/scheme-json-rpc.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jsampz2ahs18z6yh9b5l3lkj8ycnavs0vg9sjngdj3w3zvrdcvm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'change-to-guile-dir
+ (lambda _
+ (chdir "guile"))))))
+ (inputs (list guile-3.0 guile-srfi-145 guile-srfi-180))
+ (native-inputs (list pkg-config))
+ (synopsis "Library providing JSON-RPC capability for Guile Scheme")
+ (description
+ "This library implements parts of the
@uref{https://www.jsonrpc.org/specification,JSON-RPC specification}, allowing
for calling methods on remote servers by exchanging JSON objects.")
- (home-page "https://codeberg.org/rgherdt/scheme-json-rpc/")
- (license license:expat))))
+ (home-page "https://codeberg.org/rgherdt/scheme-json-rpc/")
+ (license license:expat)))
(define-public guile-squee
(let ((commit "9f2609563fc53466e46d37c8d8d2fbcfce67b2ba")
@@ -2505,14 +2502,14 @@ many readers as needed).")
(define-public guile-ncurses
(package
(name "guile-ncurses")
- (version "3.0")
+ (version "3.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/guile-ncurses/guile-ncurses-"
version ".tar.gz"))
(sha256
(base32
- "038xbffalhymg26lvmzgf7ljilxz2f2zmqg5r5nfzbipfbprwjhf"))))
+ "0cypz1ikw66n8bc2klsnnaj1plpl22dwq6pwyc7dvffamz7fi2gf"))))
(build-system gnu-build-system)
(inputs (list ncurses guile-3.0))
(native-inputs (list pkg-config))
@@ -2539,8 +2536,7 @@ many readers as needed).")
(substitute* files
(("\"libguile-ncurses\"")
(format #f "\"~a/lib/guile/~a/libguile-ncurses\""
- out (target-guile-effective-version))))
- #t))))))
+ out (target-guile-effective-version))))))))))
(home-page "https://www.gnu.org/software/guile-ncurses/")
(synopsis "Guile bindings to ncurses")
(description
@@ -3050,7 +3046,7 @@ format is also supported.")
(propagated-inputs
(list guile-cairo guile-rsvg))
(native-inputs
- (list autoconf automake librsvg pkg-config texinfo))
+ (list autoconf automake (librsvg-for-system) pkg-config texinfo))
(home-page "https://git.elephly.net/software/guile-picture-language.git")
(synopsis "Picture language for Guile")
(description
@@ -3848,7 +3844,7 @@ debugging code.")
(define-public guile-png
(package
(name "guile-png")
- (version "0.6.0")
+ (version "0.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3857,7 +3853,7 @@ debugging code.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0i0q2h4kfp1mj5m3wnz2hk6z895001j38s5vkbhkdxf05cjvwkky"))))
+ "0nkim662lb48y8n5hik8rrj76600v2inwaxwnfpdny7h2j0yq1wm"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
@@ -5349,7 +5345,7 @@ GitLab instance.")
(define-public guile-smc
(package
(name "guile-smc")
- (version "0.6.0")
+ (version "0.6.2")
(source
(origin
(method git-fetch)
@@ -5359,7 +5355,7 @@ GitLab instance.")
(file-name (string-append name "-" version))
(sha256
(base32
- "15b8m30kjl46p44xjd65vv1bv60hy130zfskkcsrj10fzahyk9zd"))))
+ "11083lj048ab5zsdgwpkshxi8v5nfdr7kvmmslszbi7lq2pwfqig"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings