summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-15 18:20:38 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-15 18:47:00 +0200
commite9ff5d51e3297089e66c124195e1f1b42dbded65 (patch)
treece3993c90b76a2275b57bf3231628966897ee122 /gnu/packages/guile-xyz.scm
parent43cdc8a07517e936812782c313fe145bcf5c7ed3 (diff)
parentb696fb41bc0dfcb7130a5aa6d69aff2ae191c283 (diff)
downloadguix-patches-e9ff5d51e3297089e66c124195e1f1b42dbded65.tar
guix-patches-e9ff5d51e3297089e66c124195e1f1b42dbded65.tar.gz
Merge branch 'master' into gnome-team.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm74
1 files changed, 48 insertions, 26 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 8c0eab7d18..87a056752f 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -728,7 +728,7 @@ you send to a FIFO file.")
(define-public guile-dsv
(package
(name "guile-dsv")
- (version "0.6.0")
+ (version "0.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -737,12 +737,19 @@ you send to a FIFO file.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0llivcgb7idglsapcmvb2qscds7768f2xfgr4lns8mzl2xf5hwvv"))))
+ "0shrzmbh6x3n3xzpcijkxk3f73z6m1i50zgc2dnnccwf4j1c78p2"))))
(build-system gnu-build-system)
- (native-inputs
- (list autoconf automake pkg-config texinfo help2man))
- (inputs (list guile-3.0))
- (propagated-inputs (list guile-lib))
+ (native-inputs (list autoconf
+ automake
+ pkg-config
+ texinfo
+ help2man
+ ;; needed when cross-compiling.
+ guile-3.0
+ guile-lib
+ guile-smc))
+ (inputs (list bash-minimal guile-3.0))
+ (propagated-inputs (list guile-lib guile-smc))
(arguments
`(#:modules (((guix build guile-build-system)
#:select (target-guile-effective-version))
@@ -756,32 +763,41 @@ you send to a FIFO file.")
(bin (string-append out "/bin"))
(guile-lib (assoc-ref inputs "guile-lib"))
(version (target-guile-effective-version))
- (scm (string-append "/share/guile/site/"
- version))
- (go (string-append "/lib/guile/"
- version "/site-ccache")))
+ (scm (string-append "/share/guile/site/" version))
+ (go (string-append "/lib/guile/" version
+ "/site-ccache")))
(wrap-program (string-append bin "/dsv")
`("GUILE_LOAD_PATH" prefix
- (,(string-append out scm)
- ,(string-append guile-lib scm)))
+ (,(string-append out scm) ,(string-append
+ guile-lib scm)))
`("GUILE_LOAD_COMPILED_PATH" prefix
- (,(string-append out go)
- ,(string-append guile-lib go)))))
- #t)))))
+ (,(string-append out go) ,(string-append guile-lib
+ go))))) #t)))))
(home-page "https://github.com/artyom-poptsov/guile-dsv")
(synopsis "DSV module for Guile")
(description
- "Guile-DSV is a GNU Guile module for working with the
-delimiter-separated values (DSV) data format. Guile-DSV supports the
-Unix-style DSV format and RFC 4180 format.")
+ "Guile-DSV is a GNU Guile module for working with the delimiter-separated
+values (DSV) data format. Guile-DSV supports the Unix-style DSV format and RFC 4180
+style format. Also Guile-DSV includes a console program named @code{dsv} that allows
+to view and process DSV data, including such operations as delimiter change,
+conversion from one DSV standard to another and printing the data as pseudographics
+tables.")
(license license:gpl3+)))
(define-public guile2.2-dsv
(package
(inherit guile-dsv)
(name "guile2.2-dsv")
- (inputs (list guile-2.2))
- (propagated-inputs `(("guile-lib" ,guile2.2-lib)))))
+ (native-inputs (modify-inputs (package-native-inputs guile-dsv)
+ (replace "guile-smc" guile2.2-smc)
+ (replace "guile" guile-2.2)
+ (replace "guile-lib" guile2.2-lib)))
+ (inputs (modify-inputs (package-inputs guile-dsv)
+ (replace "guile" guile-2.2)
+ (replace "guile-lib" guile2.2-lib)))
+ (propagated-inputs (modify-inputs (package-propagated-inputs guile-dsv)
+ (replace "guile-lib" guile2.2-lib)
+ (replace "guile-smc" guile2.2-smc)))))
(define-public guile-fibers-1.3
(package
@@ -3840,7 +3856,7 @@ debugging code.")
(define-public guile-png
(package
(name "guile-png")
- (version "0.7.0")
+ (version "0.7.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3849,10 +3865,13 @@ debugging code.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0nkim662lb48y8n5hik8rrj76600v2inwaxwnfpdny7h2j0yq1wm"))))
+ "0y65795s9bs69msqvdbq8h34n00bkfs5v1d44wz21nwdffvq6557"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (list
+ #:make-flags #~(list "GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+ #:phases #~(modify-phases %standard-phases
+ (delete 'strip))))
(native-inputs (list autoconf
automake
pkg-config
@@ -3868,9 +3887,9 @@ debugging code.")
(synopsis "PNG file parsing library for Guile")
(description
"@code{guile-png} is a GNU Guile library for working with the
-@url{https://en.wikipedia.org/wiki/PNG, PNG format}. This library provides
-API for reading and writing PNG data, as well as some basic image processing
-filters.")
+@url{https://en.wikipedia.org/wiki/PNG, PNG format}. This library provides API for
+reading and writing PNG data, as well as some graphic primitives and basic image
+processing filters.")
(license license:gpl3+)))
(define-public nomad
@@ -5413,6 +5432,9 @@ with a FSM is being built (for example, from a Makefile.)")
(package
(inherit guile-smc)
(name "guile2.2-smc")
+ (native-inputs (modify-inputs (package-native-inputs guile-smc)
+ (replace "guile" guile-2.2)
+ (replace "guile-lib" guile2.2-lib)))
(inputs (modify-inputs (package-inputs guile-smc)
(replace "guile" guile-2.2)
(replace "guile-lib" guile2.2-lib)))))