summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-23 21:09:49 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-23 21:09:49 +0200
commite38d6a9c2fba815ac34e74baa843f15e33846813 (patch)
tree0a3dd602449386119fc15de32a5cf7e5f607b2a1 /gnu/packages/guile-xyz.scm
parentda716c8b9cdc358609a368bd5da70b31cd97a938 (diff)
parentcbd20d627497053871db863970c07d93c7081786 (diff)
downloadguix-patches-e38d6a9c2fba815ac34e74baa843f15e33846813.tar
guix-patches-e38d6a9c2fba815ac34e74baa843f15e33846813.tar.gz
Merge branch 'master' into gnome-team
Change-Id: Ib6f55bebef2fb235fa59fd5442102a3e0ace3191
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm30
1 files changed, 28 insertions, 2 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 871d418bc2..982eebacba 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3295,6 +3295,32 @@ serializing continuations or delimited continuations.")
from @code{tree-il}.")
(license license:lgpl2.0+)))
+(define-public guile-hoot
+ (package
+ (name "guile-hoot")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://spritely.institute/files/releases"
+ "/guile-hoot/guile-hoot-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1087rcj22hk6fcbqajm268f1q2c3kbizah8wy1z0aqkfliwc309g"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0"
+ "WASM_HOST=hoot")))
+ (native-inputs
+ (list autoconf automake pkg-config texinfo))
+ (inputs
+ (list guile-next))
+ (synopsis "WebAssembly compiler backend for Guile")
+ (description "Guile Hoot is a WebAssembly compiler backend for GNU Guile
+and standalone WASM toolchain.")
+ (home-page "https://spritely.institute/hoot")
+ (license (list license:asl2.0 license:lgpl3+))))
+
(define-public guile-file-names
(package
(name "guile-file-names")
@@ -5444,7 +5470,7 @@ with a FSM is being built (for example, from a Makefile.)")
(define-public guile-ini
(package
(name "guile-ini")
- (version "0.5.3")
+ (version "0.5.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5453,7 +5479,7 @@ with a FSM is being built (for example, from a Makefile.)")
(file-name (string-append name "-" version))
(sha256
(base32
- "03pdbas7f6r2q3jbcn68xpm57hika3byb4rhsf0544kw6yk3bm8q"))))
+ "10glfdhyv8h58cmf0xl1g7jk05pd5hzdncc2c709b8pyncrdiakh"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings