summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-04-04 10:36:02 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 10:36:02 +0100
commit031f4fabc12fd97ba9769d2a00f78c6d42c5a724 (patch)
treeef28cbc228606d9865c0df9da363f4f67214ce21 /gnu/packages/guile-xyz.scm
parent188d18fc47f0d38edfe06e3e5834fa8587bd300b (diff)
downloadguix-patches-031f4fabc12fd97ba9769d2a00f78c6d42c5a724.tar
guix-patches-031f4fabc12fd97ba9769d2a00f78c6d42c5a724.tar.gz
gnu: guile-lmdb: Update to 0.0.1-1.ea9aa1d.
* gnu/packages/guile-xyz.scm (guile-lmdb): Update to 0.0.1-1.ea9aa1d. [description]: Extend it. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I136f8feb91540a5a1564f9f693446dc65ec57f2e
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index f52037daa9..94910db5f9 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2025,8 +2025,8 @@ for MySQL.")
(license license:gpl2+)))
(define-public guile-lmdb
- (let ((commit "438143ca9ba157faec6f4c2740092c31c733fbfe")
- (revision "0"))
+ (let ((commit "ea9aa1d4b13e03f9fd23ec73d8884f4fae79666b")
+ (revision "1"))
(package
(name "guile-lmdb")
(version (git-version "0.0.1" revision commit))
@@ -2038,7 +2038,7 @@ for MySQL.")
(file-name (git-file-name name version))
(sha256
(base32
- "0p43c8ppbhzpi944in0z2jqr7acl8pm7s1x0p5f0idqda6n6f828"))))
+ "1li92ldyjvbqkhqnkndgw0jk1avkzq9jkbmk8dqiby4na72sxi8k"))))
(build-system guile-build-system)
(arguments
(list
@@ -2059,7 +2059,8 @@ for MySQL.")
Most names are the same as LMDB ones, except for prefix absence.
Several conveniences are added on top:
@itemize
-@item @code{call-with-env-and-txn} and @code{call-with-cursor} wrappers.
+@item @code{call-with-env-and-txn}, @code{call-with-cursor}, and
+@code{call-with-wrapped-cursor} helpers and respective @code{with-} macros.
@item @code{for-cursor} procedure for cursor iteration.
@item @code{val} and @code{stat} types.
@item Error signaling instead of integer return values.