summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:25:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:27:51 +0200
commit075df3d3e2f86ad2548075969b34402a3c40ec42 (patch)
tree303b422a84ce5ee1fccff610eaf83b20919e8b87 /gnu/packages/guile-xyz.scm
parentaba40a6b7fdce56fe439668b3152ae4d4ddd1551 (diff)
parentb2721c3656e0ddf76dcccccfbacaaa309d2f47fe (diff)
downloadguix-patches-075df3d3e2f86ad2548075969b34402a3c40ec42.tar
guix-patches-075df3d3e2f86ad2548075969b34402a3c40ec42.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 3c93779209..1ef872ffe1 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3145,6 +3145,16 @@ list of components. This module takes care of that for you.")
(ice-9 rdelim))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-dotted-circle-from-combining-character
+ ;; The test/string.scm files contain ◌̀, which is a dotted circle
+ ;; (U+25cc) followed by an upper combining character (U+0300). The
+ ;; old guile 3.0.2 reader incorrectly ignores the dotted circle,
+ ;; and parses it as the combining character alone, but the new
+ ;; guile reader does not.
+ ;; See https://github.com/spk121/guile-gi/issues/112
+ (lambda* _
+ (substitute* "test/string.scm"
+ (("#\\\\◌̀") "#\\x0300"))))
(add-after 'unpack 'patch-references-to-extension
(lambda* (#:key outputs #:allow-other-keys)
(let ((effective (read-line