summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-09-08 19:47:44 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-10-03 19:32:50 +0530
commitc4698e50f2a0bb38f171bf85ed0c99db8fb6e2f1 (patch)
tree161010b618babf28387ea90d88ea9d25e62ec234 /gnu/packages/guile-xyz.scm
parent658cc8b25f123c4c71d39fcd170d86b17c157516 (diff)
downloadguix-patches-c4698e50f2a0bb38f171bf85ed0c99db8fb6e2f1.tar
guix-patches-c4698e50f2a0bb38f171bf85ed0c99db8fb6e2f1.tar.gz
gnu: guile-dbd-sqlite3: Inherit from guile-dbi.
* gnu/packages/guile-xyz.scm (guile-dbd-sqlite3): Inherit from guile-dbi. Remove version, source, build-system, home-page and license fields. [arguments]: Replace chdir phase. Delete patch-extension-path phase. [native-inputs]: Replace guile-dbi-bootstrap with guile-dbi.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm35
1 files changed, 16 insertions, 19 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0363dd60c1..5ebc49a39c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1587,32 +1587,29 @@ It currently supports MySQL, Postgres and SQLite3.")
(define-public guile-dbd-sqlite3
(package
+ (inherit guile-dbi)
(name "guile-dbd-sqlite3")
- (version "2.1.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://example.org") ;only hosted on Software Heritage
- (commit "0758c615e9e85ad76d153d5dc6179881f1f50089")))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1rwf3z6ib6nkhfnk2nw8p6fqirdx2pparcrlmsm0i2ii62plpqhb"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("guile-dbi-bootstrap" ,guile-dbi-bootstrap))) ; only required for headers
+ (arguments
+ (substitute-keyword-arguments (package-arguments guile-dbi)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'chdir
+ (lambda _
+ ;; The upstream Git repository contains all the code, so change
+ ;; to the directory specific to guile-dbd-sqlite3.
+ (chdir "guile-dbd-sqlite3")))
+ (delete 'patch-extension-path)))))
(inputs
`(("sqlite" ,sqlite)
("zlib" ,(@ (gnu packages compression) zlib))))
+ (native-inputs
+ `(("guile-dbi" ,guile-dbi) ; only required for headers
+ ("pkg-config" ,pkg-config)
+ ,@(package-native-inputs guile-dbi)))
(synopsis "Guile DBI driver for SQLite")
- ;; Unofficial home-page.
- ;; Added by b9cbfa52f71505de8447fefabd97f16d0a9cbde6 (2016-06)
- (home-page "https://github.com/jkalbhenn/guile-dbd-sqlite3")
(description
"guile-dbi is a library for Guile that provides a convenient interface to
-SQL databases. This package implements the interface for SQLite.")
- (license license:gpl2+)))
+SQL databases. This package implements the interface for SQLite.")))
(define-public guile-dbd-postgresql
(let ((commit "e97589b6b018b206c901e4cc24db463407a4036b")