summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2021-12-05 09:53:43 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-05 09:53:59 +0100
commit030d9b261fc81cf8047cc8f4dfd1f8e59e1fd3b7 (patch)
tree9f82b94026f17a0f6b1f6510f018bdaa21102d45 /gnu/packages/guile-xyz.scm
parent20d525a842ca5d22edc4e2aa4a5d8225c2f5306c (diff)
downloadguix-patches-030d9b261fc81cf8047cc8f4dfd1f8e59e1fd3b7.tar
guix-patches-030d9b261fc81cf8047cc8f4dfd1f8e59e1fd3b7.tar.gz
gnu: Add guile-ini.
* gnu/packages/guile-xyz.scm (guile-ini): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 508b4b44d5..32dc08b0e2 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4944,3 +4944,39 @@ compiler itself. It produces a Scheme code for an FSM from the PlantUML
format. This tool is meant to be called on a PlantUML file when a program
with a FSM is being built (for example, from a Makefile.)")
(license license:gpl3)))
+
+(define-public guile-ini
+ (package
+ (name "guile-ini")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-ini")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0injn60530valhx3gsmdp72g6z886yf0n08hscky21h3dafm14kc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("bash" ,bash-minimal)
+ ("guile" ,guile-3.0)
+ ("guile-lib" ,guile-lib)))
+ (propagated-inputs
+ `(("guile-smc" ,guile-smc)))
+ (home-page "https://github.com/artyom-poptsov/guile-ini")
+ (synopsis "Guile library for INI format support")
+ (description
+ "@code{guile-ini} is a GNU Guile library for working with the
+@url{https://en.wikipedia.org/wiki/INI_file, INI format}. This library
+provides API for reading and writing INI data.")
+ (license license:gpl3)))