summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 14:01:04 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 14:01:04 -0500
commit8a8e491258adadcb6983a4051fa71e60c0dd7849 (patch)
tree2e098fbb9fc9c1569b02ebdd601da55c0575154a /gnu/packages/gtk.scm
parent612e38bd29a42409cd6030d745ead844509e8c6e (diff)
downloadguix-patches-8a8e491258adadcb6983a4051fa71e60c0dd7849.tar
guix-patches-8a8e491258adadcb6983a4051fa71e60c0dd7849.tar.gz
gnu: gtk+: Conditionally disable the tree-relationships test.
* gnu/packages/gtk.scm (gtk+)[phases] {disable-failing-tests}: Disable the tree-relationships test on non-x86_64 targets.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 042eb639c7..e8ac0b79bb 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1053,7 +1053,11 @@ application suites.")
'()))
(substitute* "testsuite/a11y/Makefile.in"
(("accessibility-dump tree-performance text children derive")
- "tree-performance text children derive"))
+ "tree-performance text children derive")
+ ,@(if (not (target-x86-64?))
+ '((("value misc tree-relationships util")
+ "value misc util"))
+ '()))
(substitute* "testsuite/reftests/Makefile.in"
(("TEST_PROGS = gtk-reftest")
"TEST_PROGS = "))