summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-19 23:37:26 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:37 -0500
commitb78f0cbff4a5243d7bf2d6fc62c810d8f85b82a4 (patch)
tree0a55515bd64a8f4b31f6782c4dc05919e94f29f9 /gnu/packages/gtk.scm
parent8b1a6ee69d5290e619b3d9115d130c18347efc44 (diff)
downloadguix-patches-b78f0cbff4a5243d7bf2d6fc62c810d8f85b82a4.tar
guix-patches-b78f0cbff4a5243d7bf2d6fc62c810d8f85b82a4.tar.gz
gnu: gtk: Update to 4.4.1.
* gnu/packages/patches/gtk-introspection-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gtk.scm (gtk): Update to 4.4.1. [origin]: Apply new patch. [phases]{pre-check}: Set TZDIR. [native-inputs]: Add graphene, python-pygobject and tzdata.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 77b348d18d..58e428c921 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1059,7 +1059,7 @@ application suites.")
(define-public gtk
(package
(name "gtk")
- (version "4.2.1")
+ (version "4.4.1")
(source
(origin
(method url-fetch)
@@ -1067,9 +1067,10 @@ application suites.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1rh9fd5axf79pmd93hb2fmmflic5swcvqvq6vqghlgz4bmvnjc82"))
+ (base32 "1x6xlc063nqp7cg6py4kq1kpw9pkq49ifk5kki0brc667ncdmahg"))
(patches
- (search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"))))
+ (search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"
+ "gtk-introspection-test.patch"))))
(build-system meson-build-system)
(outputs '("out" "bin" "doc"))
(arguments
@@ -1122,7 +1123,7 @@ application suites.")
(lambda _
(setenv "XDG_CACHE_HOME" (getcwd))))
(add-before 'check 'pre-check
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
;; Tests require a running X server.
(system "Xvfb :1 +extension GLX &")
(setenv "DISPLAY" ":1")
@@ -1131,7 +1132,10 @@ application suites.")
;; Tests look for those variables.
(setenv "XDG_RUNTIME_DIR" (getcwd))
;; For missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")))
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ ;; Required for the calendar test.
+ (setenv "TZDIR" (search-input-directory inputs
+ "share/zoneinfo"))))
(add-after 'install 'move-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1166,10 +1170,12 @@ application suites.")
("gettext-minimal" ,gettext-minimal)
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection) ;for building introspection data
+ ("graphene" ,graphene)
("gtk-doc" ,gtk-doc) ;for building documentation
("intltool" ,intltool)
("libxslt" ,libxslt) ;for building man-pages
("pkg-config" ,pkg-config)
+ ("python-pygobject" ,python-pygobject)
;; These python modules are required for building documentation.
("python-jinja2" ,python-jinja2)
("python-markdown" ,python-markdown)
@@ -1178,6 +1184,7 @@ application suites.")
("python-toml" ,python-toml)
("python-typogrify" ,python-typogrify)
("sassc" ,sassc) ;for building themes
+ ("tzdata" ,tzdata-for-tests)
("vala" ,vala)
("xorg-server-for-tests" ,xorg-server-for-tests)))
(inputs