summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-15 16:24:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:14 -0500
commit8dec1804a550257034730f1ecd618a3589a64625 (patch)
treeb0e36497d1165ba44d0116e59f9996cfb35298b3 /gnu/packages/gtk.scm
parent0dc52fc25a7ad44f955be9b1f19827da1fba8af9 (diff)
downloadguix-patches-8dec1804a550257034730f1ecd618a3589a64625.tar
guix-patches-8dec1804a550257034730f1ecd618a3589a64625.tar.gz
gnu: colord-minimal: Introduce minimal variant.
* gnu/packages/gnome.scm (colord-minimal): New minimal variant that doesn't require Inkscape to be built (through gtk-doc). Remove trailing #t. [configure-flags]: Disable docs and manpage generation. Sort order. (colord): Rewrite in terms of colord-minimal. [configure-flags]: Enable manpages and bash completion. [phases]{fix-bash-completion-dir}: New phase. [native-inputs]: Add bash_completion, docbook-xsl-ns and libxml2. * gnu/packages/gtk.scm (gtk+)[inputs]{colord}: Use the colord-minimal variant to prevent a cycle with Inkscape.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 1dd2c6c184..a515bca5ac 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1023,7 +1023,7 @@ application suites.")
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)))
(inputs
- `(("colord" ,colord)
+ `(("colord" ,colord-minimal) ;to prevent a cycle with inkscape
("cups" ,cups)
("graphene" ,graphene)
("harfbuzz" ,harfbuzz)