summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-19 22:59:02 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-20 08:57:02 -0500
commit76df1ad3df794418c0687b59e9ce80a96d15e16c (patch)
treef312428e04b89cbd8310da1f270f59ebebfe4d5d /gnu/packages/gtk.scm
parent58c42ce41df50e77977d2559ce949b36e683984f (diff)
downloadguix-patches-76df1ad3df794418c0687b59e9ce80a96d15e16c.tar
guix-patches-76df1ad3df794418c0687b59e9ce80a96d15e16c.tar.gz
gnu: gtk: Guard against timeouts in the test suite.
This change piggy backs on the improvements to the meson-build-system made in dfcc96d8f48716ae5aefb383c58b153d5bcb407c; it's motivated by timeouts that occurred in the GTK test suite while building on a heavily loaded machine. * gnu/packages/gtk.scm (gtk)[parallel-tests]: New argument. [test-options]: New argument, which now includes --suite=gtk and --no-suite=gsk-compare-broadway, to match what upstream uses. [phases]{check}: Remove override.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 09e044d7e7..042eb639c7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1116,6 +1116,12 @@ application suites.")
'("-Dgtk_doc=false")
'("-Dgtk_doc=true"))
"-Dman-pages=true")
+ #:parallel-tests? #f ;parallel tests are not supported
+ #:test-options '("--setup=x11" ;defaults to wayland
+ ;; Use the same test options as upstream uses for
+ ;; their CI.
+ "--suite=gtk"
+ "--no-suite=gsk-compare-broadway")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
@@ -1154,13 +1160,6 @@ application suites.")
(setenv "XDG_RUNTIME_DIR" (getcwd))
;; For missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "MESON_TESTTHREADS" "1")
- ;; Run tests using the x11 setup,
- ;; instead of the default wayland.
- (invoke "meson" "test" "--setup=x11"))))
(add-after 'install 'move-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))