summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 01:38:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:45 -0400
commit1c09ed37211d983d04e626d736df8f69f504630d (patch)
treed0fec6d20cf5871a95ee6c213e4a260611216f6b /gnu/packages/gtk.scm
parented3c97f53ef5d60f103b93d15ccce5db052bfad1 (diff)
downloadguix-patches-1c09ed37211d983d04e626d736df8f69f504630d.tar
guix-patches-1c09ed37211d983d04e626d736df8f69f504630d.tar.gz
gnu: Remove python2-pygtk.
* gnu/packages/gtk.scm (python2-pygtk): Delete variable.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm70
1 files changed, 0 insertions, 70 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index af695d118b..2518b98756 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1940,76 +1940,6 @@ printing and other features typical of a source code editor.")
;; Dual-licensed under LGPL 2.1 or Mozilla Public License 1.1
(license (list license:lgpl2.1 license:mpl1.1)))))
-(define-public python2-pygtk
- (package
- (name "python2-pygtk")
- (version "2.24.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources"
- "/pygtk/" (version-major+minor version)
- "/pygtk-" version ".tar.bz2"))
- (sha256
- (base32
- "04k942gn8vl95kwf0qskkv6npclfm31d78ljkrkgyqxxcni1w76d"))))
- (build-system gnu-build-system)
- (outputs '("out"
- "doc")) ;13 MiB of gtk-doc HTML
- (native-inputs
- (list pkg-config))
- (inputs
- `(("python" ,python-2)
-
- ;; XXX: The package fails to build with the latest Pango (propagated
- ;; from GTK+2), so we provide it with this older version.
- ("pango" ,pango-1.42)
-
- ("libglade" ,libglade)
- ("glib" ,glib)))
- (propagated-inputs
- `(("python-pycairo" ,python2-pycairo) ;loaded at runtime
- ("python-pygobject" ,python2-pygobject-2) ;referenced in pc file
- ("gtk+" ,gtk+-2)))
- (arguments
- `(#:tests? #f
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'set-gtk-doc-directory
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Install documentation to "doc".
- (let ((doc (assoc-ref outputs "doc")))
- (substitute* "docs/Makefile.in"
- (("TARGET_DIR = \\$\\(datadir\\)")
- (string-append "TARGET_DIR = " doc))))))
- (add-after 'configure 'fix-codegen
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "pygtk-codegen-2.0"
- (("^prefix=.*$")
- (string-append
- "prefix="
- (assoc-ref inputs "python-pygobject") "\n")))))
- (add-after 'install 'install-pth
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; pygtk's modules are stored in a subdirectory of
- ;; python's site-packages directory. Add a .pth file so
- ;; that python will add that subdirectory to its module
- ;; search path.
- (let* ((out (assoc-ref outputs "out"))
- (site (string-append out "/lib/python"
- ,(version-major+minor
- (package-version python-2))
- "/site-packages")))
- (call-with-output-file (string-append site "/pygtk.pth")
- (lambda (port)
- (format port "gtk-2.0~%")))))))))
- (home-page "http://www.pygtk.org/")
- (synopsis "Python bindings for GTK+")
- (description
- "PyGTK allows you to write full featured GTK programs in Python. It is
-targeted at GTK 2.x, and can be used in conjunction with gnome-python to
-write GNOME applications.")
- (license license:lgpl2.1+)))
-
(define-public perl-cairo
(package
(name "perl-cairo")