summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-08-19 10:50:23 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-19 16:01:27 +0200
commit100520bab333525faf60fc5149b3b3f31cace304 (patch)
tree8ec7ba5721f739f8f3eefb0a585d9045d8d4682c /gnu/packages/gtk.scm
parentb8991c5e1c1b95c981c3a43cc3a22ba5c5f3209f (diff)
downloadguix-patches-100520bab333525faf60fc5149b3b3f31cace304.tar
guix-patches-100520bab333525faf60fc5149b3b3f31cace304.tar.gz
gnu: gtk-doc: Update to 1.33.2.
* gnu/packages/patches/gtk-doc-respect-xml-catalog.patch: New file. * gnu/local.mk (DIST_PATCH_DATA): Add it. * gnu/packages/gtk.scm (gtk-doc): Update to 1.33.2. [source]: Add gtk-doc-respect-xml-catalog.patch patch. [build-system]: Switch to meson. [arguments]: Remove fix-docbook phase. Remove configure flags that are no longer needed. [outputs]: Remove the help output since the help-dir option no longer exists.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm36
1 files changed, 7 insertions, 29 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 007eda146b..bd689e466c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2047,7 +2047,7 @@ information.")
(define-public gtk-doc
(package
(name "gtk-doc")
- (version "1.32")
+ (version "1.33.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -2055,9 +2055,10 @@ information.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0z4h1dggpimygdp719l457jvqilps4qcfpk31jmj3jqpzcsg03ny"))))
- (build-system glib-or-gtk-build-system)
- (outputs '("out" "help"))
+ "0hxza8qp52lrq7s1vbilz2vh4170cail560zi8khl0zb42d706yc"))
+ (patches
+ (search-patches "gtk-doc-respect-xml-catalog.patch"))))
+ (build-system meson-build-system)
(arguments
`(#:parallel-tests? #f
#:phases
@@ -2078,40 +2079,17 @@ information.")
#t))
(add-after 'unpack 'disable-failing-tests
(lambda _
- (substitute* "tests/Makefile.in"
+ (substitute* "tests/Makefile.am"
(("annotations.sh bugs.sh empty.sh fail.sh gobject.sh program.sh")
""))
#t))
- (add-before 'configure 'fix-docbook
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "configure"
- ;; The configure check is overzealous about making sure that
- ;; things are in place -- it uses the xmlcatalog tool to make
- ;; sure that docbook-xsl is available, but this tool can only
- ;; look in one catalog file, unlike the $XML_CATALOG_FILES
- ;; variable that Guix defines. Fool the test by using the
- ;; docbook-xsl catalog explicitly and get on with life.
- (("\"\\$XML_CATALOG_FILE\" \
-\"http://docbook.sourceforge.net/release/xsl/")
- (string-append (car (find-files (assoc-ref inputs "docbook-xsl")
- "^catalog.xml$"))
- " \"http://docbook.sourceforge.net/release/xsl/")))
- #t))
(add-after 'install 'wrap-executables
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(for-each (lambda (prog)
(wrap-program prog
`("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))))
- (find-files (string-append out "/bin")))
- #t))))
- #:configure-flags
- (list (string-append "--with-xml-catalog="
- (assoc-ref %build-inputs "docbook-xml")
- "/xml/dtd/docbook/catalog.xml")
- (string-append "--with-help-dir="
- (assoc-ref %outputs "help")
- "/share/help"))))
+ (find-files (string-append out "/bin")))))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")