summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-03-05 22:40:46 +0800
committerLudovic Courtès <ludo@gnu.org>2022-04-04 22:58:02 +0200
commitef3cae59a2bc29b666e1c6b468b286f4cbb4974c (patch)
tree27a0a53f9aacbda3f21fa273d178a611450d1d6b /gnu/packages/gtk.scm
parent4df7fe14ff47d8858f5c7fc7036b0bb1cc662a86 (diff)
downloadguix-patches-ef3cae59a2bc29b666e1c6b468b286f4cbb4974c.tar
guix-patches-ef3cae59a2bc29b666e1c6b468b286f4cbb4974c.tar.gz
gnu: gtk: Update to 4.6.1.
* gnu/local.mk (dist_patch_DATA): Remove gtk-introspection-test.patch. * gnu/packages/patches/gtk-introspection-test.patch: Remove. * gnu/packages/gtk.scm (gtk): Update to 4.6.1. [source]: Remove stale patch. [arguments]<phases>: Add 'patch-rst2man' phase, correct the binary name of rst2man to 'rst2man.py' [inputs]: Add libjpeg-turbo, libpng, libtiff. [native-inputs]: Add python-docutils. [propagated-inputs]: Use pango-next. * gnu/packages/fcitx5.scm (fcitx5-gtk)[arguments]: Disable GTK4 build. <configure-flags>: Add "-DENABLE_GTK_IM_MODULE=OFF". <phases>: In phase "patch-install-prefix", Remove GTK4 code. [inputs]: Remove package gtk. [outputs]: Remove output "gtk4". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 61cc7ce1cb..a45467fd6f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1076,7 +1076,7 @@ application suites.")
(define-public gtk
(package
(name "gtk")
- (version "4.4.1")
+ (version "4.6.1")
(source
(origin
(method url-fetch)
@@ -1084,10 +1084,9 @@ application suites.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1x6xlc063nqp7cg6py4kq1kpw9pkq49ifk5kki0brc667ncdmahg"))
+ (base32 "0pzcs24j67f90kjcp6apgn6rffynxksjm1m7d3an7kdv3k90hmfq"))
(patches
- (search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"
- "gtk-introspection-test.patch"))))
+ (search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"))))
(build-system meson-build-system)
(outputs '("out" "bin" "doc"))
(arguments
@@ -1117,6 +1116,10 @@ application suites.")
(add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
(assoc-ref glib-or-gtk:%standard-phases
'generate-gdk-pixbuf-loaders-cache-file))
+ (add-after 'unpack 'patch-rst2man
+ (lambda _
+ (substitute* "docs/reference/gtk/meson.build"
+ (("find_program\\('rst2man'") "find_program('rst2man.py'"))))
(add-after 'unpack 'patch
(lambda* (#:key inputs native-inputs outputs #:allow-other-keys)
;; Correct DTD resources of docbook.
@@ -1194,6 +1197,7 @@ application suites.")
("pkg-config" ,pkg-config)
("python-pygobject" ,python-pygobject)
;; These python modules are required for building documentation.
+ ("python-docutils" ,python-docutils)
("python-jinja2" ,python-jinja2)
("python-markdown" ,python-markdown)
("python-markupsafe" ,python-markupsafe)
@@ -1216,7 +1220,10 @@ application suites.")
iso-codes
json-glib
libcloudproviders ;for cloud-providers support
+ libjpeg-turbo
+ libpng
librsvg
+ libtiff
python
rest
tracker)) ;for filechooser search support
@@ -1239,7 +1246,7 @@ application suites.")
("libxkbcommon" ,libxkbcommon)
("libxrandr" ,libxrandr)
("libxrender" ,libxrender)
- ("pango" ,pango)
+ ("pango" ,pango-next)
("vulkan-headers" ,vulkan-headers)
("vulkan-loader" ,vulkan-loader) ;for vulkan graphics API support
("wayland" ,wayland) ;for wayland display-backend