summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-09-15 20:19:39 +0800
committer宋文武 <iyzsong@gmail.com>2015-09-15 20:19:39 +0800
commiteb6afbcde784a72a96f3c5a70d657630d421b02a (patch)
tree5986ccc8c9ff6f3a9a8f8f74d7cd67501e26d4b1 /gnu/packages/gtk.scm
parentfd9b3b43ab92f33f3e7f5d546b34e329dbec97af (diff)
downloadguix-patches-eb6afbcde784a72a96f3c5a70d657630d421b02a.tar
guix-patches-eb6afbcde784a72a96f3c5a70d657630d421b02a.tar.gz
gnu: harfbuzz: Add "bin" output.
* gnu/packages/gtk.scm (harfbuzz)[outputs]: New field. [arguments]<#:configure-flags>: Pass '--bindir'.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f708afb190..53d8edc3c4 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -154,6 +154,7 @@ affine transformation (scale, rotation, shear, etc.).")
(base32
"1xrxlrvgyr6mm9qjxmkif2kvcah082y94gf1vqi0f0bdl1g8gp7b"))))
(build-system gnu-build-system)
+ (outputs '("out" "bin"))
(inputs
`(("cairo" ,cairo)))
(propagated-inputs
@@ -167,7 +168,9 @@ affine transformation (scale, rotation, shear, etc.).")
("python" ,python-2))) ; incompatible with Python 3 (print syntax)
(arguments
`(#:configure-flags `("--with-graphite2"
- "--with-gobject")))
+ "--with-gobject"
+ ,(string-append
+ "--bindir=" (assoc-ref %outputs "bin") "/bin"))))
(synopsis "OpenType text shaping engine")
(description
"HarfBuzz is an OpenType text shaping engine.")