summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-13 22:18:13 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-13 22:18:13 +0100
commitb97438650d43f59e7f836b3471fc0e9b321c4c59 (patch)
tree9c25ed64f1bc8c72e8406d0eaca1f4e7612ea184 /gnu/packages/gtk.scm
parentb111bceecc4d85b6147f2b672049f6a479a8c69d (diff)
downloadguix-patches-b97438650d43f59e7f836b3471fc0e9b321c4c59.tar
guix-patches-b97438650d43f59e7f836b3471fc0e9b321c4c59.tar.gz
gnu: guile-cairo: Use 'modify-phases'.
* gnu/packages/gtk.scm (guile-cairo)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm62
1 files changed, 30 insertions, 32 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0a291370e7..380fae594b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -730,38 +730,36 @@ application suites.")
(name "guile-cairo")
(version "1.4.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://download.gna.org/guile-cairo/guile-cairo-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "1f5nd9n46n6cwfl1byjml02q3y2hgn7nkx98km1czgwarxl7ws3x"))))
+ (method url-fetch)
+ (uri (string-append
+ "http://download.gna.org/guile-cairo/guile-cairo-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1f5nd9n46n6cwfl1byjml02q3y2hgn7nkx98km1czgwarxl7ws3x"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'configure 'set-module-directory
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Install modules under $out/share/guile/site/2.0.
- (let ((out (assoc-ref outputs "out")))
- (substitute* "Makefile.in"
- (("scmdir = ([[:graph:]]+).*" _ value)
- (string-append "scmdir = " value "/2.0\n")))
- (substitute* "cairo/Makefile.in"
- (("moduledir = ([[:graph:]]+).*" _ value)
- (string-append "moduledir = "
- "$(prefix)/share/guile/site/2.0/cairo\n'")))))
- (alist-cons-after
- 'install 'install-missing-file
- (lambda* (#:key outputs #:allow-other-keys)
- ;; By default 'vector-types.scm' is not installed, so do
- ;; it here.
- (let ((out (assoc-ref outputs "out")))
- (copy-file "cairo/vector-types.scm"
- (string-append out "/share/guile/site/2.0"
- "/cairo/vector-types.scm"))))
- %standard-phases))))
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-module-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Install modules under $out/share/guile/site/2.0.
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile.in"
+ (("scmdir = ([[:graph:]]+).*" _ value)
+ (string-append "scmdir = " value "/2.0\n")))
+ (substitute* "cairo/Makefile.in"
+ (("moduledir = ([[:graph:]]+).*" _ value)
+ (string-append "moduledir = "
+ "$(prefix)/share/guile/site/2.0/cairo\n'"))))))
+ (add-after 'install 'install-missing-file
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; By default 'vector-types.scm' is not installed, so do
+ ;; it here.
+ (let ((out (assoc-ref outputs "out")))
+ (copy-file "cairo/vector-types.scm"
+ (string-append out "/share/guile/site/2.0"
+ "/cairo/vector-types.scm"))))))))
(inputs
`(("guile-lib" ,guile-lib)
("expat" ,expat)
@@ -770,7 +768,7 @@ application suites.")
;; The .pc file refers to 'cairo'.
`(("cairo" ,cairo)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(home-page "http://www.nongnu.org/guile-cairo/")
(synopsis "Cairo bindings for GNU Guile")
(description