summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-04-15 14:33:39 +0200
committerKei Kebreau <kei@openmailbox.org>2017-04-15 21:10:27 -0400
commit61af2675d34a7387611623881f872fb0821ae1f5 (patch)
treeed0003d073063e752b28a111b27b89c73fe7e4b9 /gnu/packages/gtk.scm
parentfd22791e2ca08d6170cfdcd6a7134267d5bc3239 (diff)
downloadguix-patches-61af2675d34a7387611623881f872fb0821ae1f5.tar
guix-patches-61af2675d34a7387611623881f872fb0821ae1f5.tar.gz
gnu: Add graphene.
* gnu/packages/gtk.scm (graphene): New variable.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 770a8c9160..728ea2075f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Patrick Hetu <patrick.hetu@auf.org>
;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Coypright © 2017 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,6 +43,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -1419,3 +1421,41 @@ misspelled words in a GtkTextView widget.")
thereof, global hotkeys and clipboard item actions. It was forked from
Parcellite and adds bugfixes and features.")
(license license:gpl2+)))
+
+(define-public graphene
+ (package
+ (name "graphene")
+ (version "1.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/ebassi/graphene/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1zd2daj7y590wnzn4jw0niyc4fnzgxrcl9i7nwhy8b25ks2hz5wq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--enable-introspection=yes")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'autogen
+ (lambda _
+ (zero? (system* "./autogen.sh")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("which" ,which)
+ ("pkg-config" ,pkg-config)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("python" ,python)
+ ("python-2" ,python-2)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)))
+ (home-page "http://ebassi.github.io/graphene")
+ (synopsis "Thin layer of graphic data types")
+ (description "This library provides graphic types and their relative API;
+it does not deal with windowing system surfaces, drawing, scene graphs, or
+input.")
+ (license license:expat)))