summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-12-04 00:53:16 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:27:21 -0400
commitcccbe0a7cb80b10aec32a12236fff5045d791fa5 (patch)
treed10b521e59a4479ea5cded6e2bf82881aa62ffd4 /gnu/packages/gtk.scm
parentc8a12483574956d26d2ffd26ed92c16673086083 (diff)
downloadguix-patches-cccbe0a7cb80b10aec32a12236fff5045d791fa5.tar
guix-patches-cccbe0a7cb80b10aec32a12236fff5045d791fa5.tar.gz
gnu: cairo: Move documentation to separate output.
* gnu/packages/gtk.scm (cairo) [outputs]: New output "doc". [arguments]<#:configure-flags>[--with-html-dir]: New flag. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 27c132ab59..6dd281e2bc 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -134,13 +134,17 @@ tools have full access to view and control running applications.")
(sha256
(base32 "0c930mk5xr2bshbdljv005j3j8zr47gqmkry3q6qgvqky6rjjysy"))))
(build-system glib-or-gtk-build-system)
+ (outputs '("out" "doc"))
(arguments
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
#:configure-flags
(list
- "--enable-tee" ;needed for GNU Icecat
- "--enable-xml" ;for cairo-xml support
- "--disable-static")))
+ "--enable-tee" ;needed for GNU Icecat
+ "--enable-xml" ;for cairo-xml support
+ "--disable-static"
+ (string-append "--with-html-dir="
+ (assoc-ref %outputs "doc")
+ "/share/gtk-doc/html"))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python-wrapper)))