summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-12 08:58:34 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:27:20 -0400
commit9e1c11cd24dd97c65121fab1bcf463176d23f4ed (patch)
treef78a229bb5da8d23b954a5070b6c3eccd086695b /gnu/packages/gtk.scm
parent2e0eb1c946543be5bdc61c17379e048cade6cb3d (diff)
downloadguix-patches-9e1c11cd24dd97c65121fab1bcf463176d23f4ed.tar
guix-patches-9e1c11cd24dd97c65121fab1bcf463176d23f4ed.tar.gz
gnu: gtk-doc: Correct inputs.
* gnu/packages/gtk.scm (gtk-doc) [native-inputs]: Add glib:bin, perl and python-wrapper. [inputs]: Add python-anytree, python-lxml, python-parameterized, python-pygments, python-unittest2 and yelp-tools. Remove perl. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm26
1 files changed, 17 insertions, 9 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index dadd6bbf42..049815b8e5 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1798,21 +1798,29 @@ information.")
(assoc-ref %build-inputs "docbook-xml")
"/xml/dtd/docbook/catalog.xml"))))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("itstool" ,itstool)
- ("libxml" ,libxml2)
- ("gettext" ,gettext-minimal)
- ("bc" ,bc)))
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)))
(inputs
- `(("perl" ,perl)
- ("python" ,python)
- ("xsltproc" ,libxslt)
+ `(("bc" ,bc)
("dblatex" ,dblatex)
("docbook-xml" ,docbook-xml-4.3)
("docbook-xsl" ,docbook-xsl)
- ("source-highlight" ,source-highlight)
("glib" ,glib)
- ("python-six" ,python-six)))
+ ("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
+ ("python" ,python)
+ ("python-anytree" ,python-anytree)
+ ("python-lxml" ,python-lxml)
+ ("python-parameterized" ,python-parameterized)
+ ("python-pygments" ,python-pygments)
+ ("python-unittest2" ,python-unittest2)
+ ("source-highlight" ,source-highlight)
+ ("yelp-tools" ,yelp-tools)))
(home-page "https://www.gtk.org/gtk-doc/")
(synopsis "Documentation generator from C source code")
(description