summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 07:42:10 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:40:35 -0400
commitb6d7eb2c4e48eb782c0c9ebeafb3869c944bec33 (patch)
tree4929b67f739abe8dd0827f3eb5700e54d9e41b97 /gnu/packages/gtk.scm
parent7586cad0bae1232f9ed0f740feff7be66118d468 (diff)
downloadguix-patches-b6d7eb2c4e48eb782c0c9ebeafb3869c944bec33.tar
guix-patches-b6d7eb2c4e48eb782c0c9ebeafb3869c944bec33.tar.gz
gnu: pangomm: Update to 2.48.0.
* gnu/packages/gtk.scm (pango)[version]: Update to 2.48.0. [build-system]: Change from gnu to meson. [arguments]<#:glib-or-gtk?>: New argument. [native-inputs]: Add m4 and mm-common. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm25
1 files changed, 15 insertions, 10 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 8c891660e5..e1ae39a5bb 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1353,17 +1353,22 @@ library.")
(define-public pangomm
(package
(name "pangomm")
- (version "2.42.0")
+ (version "2.48.0")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0mmzxp3wniaafkxr30sb22mq9x44xckb5d60h1bl99lkzxks0vfa"))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0y2vyp6azvhrii6rzs89kr08wg8z1p562awyr812131zqdsd83ly"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t)) ; To wrap binaries and/or compile schemas
+ (native-inputs
+ `(("m4" ,m4)
+ ("mm-common" ,mm-common)
+ ("pkg-config" ,pkg-config)))
(propagated-inputs
`(("cairo" ,cairo)
("cairomm" ,cairomm)