summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 07:47:41 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:40:35 -0400
commit9d51bb87d2e52da760ee1786c282ac9c8716e82c (patch)
treeb4352d20f53a133a5ce59e0a3425e24752946900 /gnu/packages/gtk.scm
parentb6d7eb2c4e48eb782c0c9ebeafb3869c944bec33 (diff)
downloadguix-patches-9d51bb87d2e52da760ee1786c282ac9c8716e82c.tar
guix-patches-9d51bb87d2e52da760ee1786c282ac9c8716e82c.tar.gz
gnu: pangomm: Enable documentation.
* gnu/packages/gtk.scm (pangomm)[outputs]: New output "doc". [arguments]<#:configure-flags>[-Dbuild-documentation]: New flag. <#:phases>['move-doc]: New phase. [native-inputs]: Add doxygen, graphviz, perl and libxslt. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm25
1 files changed, 22 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e1ae39a5bb..956e23469d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1363,12 +1363,31 @@ library.")
(base32
"0y2vyp6azvhrii6rzs89kr08wg8z1p562awyr812131zqdsd83ly"))))
(build-system meson-build-system)
+ (outputs '("out" "doc"))
(arguments
- `(#:glib-or-gtk? #t)) ; To wrap binaries and/or compile schemas
+ `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:configure-flags
+ (list
+ "-Dbuild-documentation=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/doc")
+ (string-append doc "/share/doc"))
+ #t))))))
(native-inputs
- `(("m4" ,m4)
+ `(("dot" ,graphviz)
+ ("doxygen" ,doxygen)
+ ("m4" ,m4)
("mm-common" ,mm-common)
- ("pkg-config" ,pkg-config)))
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("xsltproc" ,libxslt)))
(propagated-inputs
`(("cairo" ,cairo)
("cairomm" ,cairomm)