summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-25 21:43:32 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-25 23:15:38 +0100
commitfa35a5f649518a5c3e41aec796ee9b6b852d93c0 (patch)
treee543a7426695fa2c30be8963fde217122d0dabb6 /gnu/packages/gtk.scm
parentefb0a04ee05f43e86b3c1fcda867a123d8ed021a (diff)
downloadguix-patches-fa35a5f649518a5c3e41aec796ee9b6b852d93c0.tar
guix-patches-fa35a5f649518a5c3e41aec796ee9b6b852d93c0.tar.gz
gnu: gtk+: Skip test that requires SVG support on non-x86_64.
* gnu/packages/gtk.scm (gtk+)[arguments]: In 'disable-failing-tests', skip 'tree-relationships' when not 'target-x86-64?'.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e8ac0b79bb..e264166004 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1061,6 +1061,12 @@ application suites.")
(substitute* "testsuite/reftests/Makefile.in"
(("TEST_PROGS = gtk-reftest")
"TEST_PROGS = "))
+ ,@(if (target-x86-64?)
+ '()
+ ;; The 'tree-relationships' test needs SVG support.
+ '((substitute* "testsuite/a11y/Makefile.in"
+ (("misc tree-relationships util")
+ "misc util"))))
#t))
(add-before 'check 'pre-check
(lambda _