summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 22:37:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:44 +0200
commit9eb02049b8a85d4d1979cc253e24fc756e653128 (patch)
tree72aac2c9d45b8ba91d518678bb2a9ac85f6e1ab6 /gnu/packages/graphviz.scm
parentdf2e9dedba0b726de14559bc67752a0a380e8d92 (diff)
downloadguix-patches-9eb02049b8a85d4d1979cc253e24fc756e653128.tar
guix-patches-9eb02049b8a85d4d1979cc253e24fc756e653128.tar.gz
gnu: dot2tex: Fix failing tests.
TeX Live packages needed to build tests are moved to native inputs because propagating them may not be a good thing. Use might already be using monolithic TeX Live, or would may have their TeX Live installation on another system. * gnu/packages/graphviz.scm (dot2tex)[native-inputs]: Add TeX Live packages necessary to build documents generated during tests. [propagated-inputs]: Remove them.
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 61e4ec7a9f..08dd73b24f 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -379,21 +379,17 @@ graphs in Graphviz's DOT language, written in pure Python.")
;; (see:
;; https://github.com/kjellmf/dot2tex/issues/94).
"-k" "not test_semicolon")))))))
- (native-inputs (list python-pytest))
+ (native-inputs
+ (list python-pytest
+ (texlive-updmap.cfg
+ (list texlive-geometry
+ texlive-pgf
+ texlive-preview
+ texlive-pstricks
+ texlive-xcolor
+ texlive-xkeyval))))
(inputs (list graphviz))
- (propagated-inputs
- (list python-pyparsing
- ;; These TeX dependencies are propagated to make it easier to build
- ;; the resulting generated TeX files, which \usepackage them.
- texlive-amsmath
- texlive-bin
- texlive-geometry
- texlive-latex-bin
- texlive-pgf
- texlive-pstricks
- texlive-preview
- texlive-xcolor
- texlive-xkeyval))
+ (propagated-inputs (list python-pyparsing))
(home-page "https://github.com/kjellmf/dot2tex")
(synopsis "Graphviz to LaTeX converter")
(description