summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-06-24 21:39:09 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-06-24 21:39:09 +0200
commitda24d067d0954cc8f8d75fa9099ad6d8a01e1098 (patch)
treef287391c8ebbb15df5890d6b5911128408ff438e /gnu/packages/graphics.scm
parent909788c0aebd8098084c009afa98d1209c9ec869 (diff)
parentf25529b08e356f89ca7cecc44295085531a8faba (diff)
downloadguix-patches-da24d067d0954cc8f8d75fa9099ad6d8a01e1098.tar
guix-patches-da24d067d0954cc8f8d75fa9099ad6d8a01e1098.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm31
1 files changed, 23 insertions, 8 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9255e49f3a..88b3b8c631 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -189,13 +189,29 @@ framebuffer graphics, audio output and input event.")
(lambda _
(substitute* "src/core/core.c"
(("..BUILDTIME..") ""))))
+ ;; TODO: Move patch to source.
+ ,@(if (target-arm32?)
+ `((add-after 'unpack 'patch-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "patch" "--force" "-p1" "-i"
+ (assoc-ref inputs "patch-file")))))
+ '())
(add-after 'unpack 'disable-configure-during-bootstrap
(lambda _
(substitute* "autogen.sh"
(("^.*\\$srcdir/configure.*") ""))
#t)))))
(native-inputs
- (list autoconf automake libtool perl pkg-config))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ,@(if (target-arm32?)
+ `(("patch" ,patch)
+ ("patch-file"
+ ,(search-patch "directfb-davinci-glibc-228-compat.patch")))
+ '())))
(inputs
(list alsa-lib
ffmpeg
@@ -1448,11 +1464,11 @@ in Julia).")
(define-public openmw-openscenegraph
;; OpenMW prefers its own fork of openscenegraph:
;; https://wiki.openmw.org/index.php?title=Development_Environment_Setup#OpenSceneGraph.
- (let ((commit "36a962845a2c87a6671fd822157e0729d164e940"))
+ (let ((commit "69cfecebfb6dc703b42e8de39eed750a84a87489"))
(hidden-package
(package
(inherit openscenegraph)
- (version (git-version "3.6" "1" commit))
+ (version (git-version "3.6" "2" commit))
(outputs (list "out"))
(source
(origin
@@ -1463,7 +1479,7 @@ in Julia).")
(file-name (git-file-name (package-name openscenegraph) version))
(sha256
(base32
- "05yhgq3qm5q277y32n5sf36vx5nv5qd3zlhz4csgd3a6190jrnia"))))
+ "1qayk2gklm8zvss90dcjfxv6717rvcmwmgmgyy1qzkli67a0zbw2"))))
(arguments
(substitute-keyword-arguments (package-arguments openscenegraph)
((#:configure-flags flags)
@@ -1471,14 +1487,14 @@ in Julia).")
#~(append
'("-DBUILD_OSG_PLUGINS_BY_DEFAULT=0"
"-DBUILD_OSG_PLUGIN_OSG=1"
+ "-DBUILD_OSG_PLUGIN_DAE=1"
"-DBUILD_OSG_PLUGIN_DDS=1"
"-DBUILD_OSG_PLUGIN_TGA=1"
"-DBUILD_OSG_PLUGIN_BMP=1"
"-DBUILD_OSG_PLUGIN_JPEG=1"
"-DBUILD_OSG_PLUGIN_PNG=1"
- "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0"
- ;; The jpeg plugin requires conversion between integers and booleans
- "-DCMAKE_CXX_FLAGS=-fpermissive")
+ "-DBUILD_OSG_PLUGIN_FREETYPE=1"
+ "-DBUILD_OSG_DEPRECATED_SERIALIZERS=0")
#$flags))
((#:phases phases)
#~(modify-phases #$phases
@@ -2596,4 +2612,3 @@ environment. It supports drawing freehand as well as basic shapes and text.
It features cut-and-paste for irregular regions or polygons.")
(home-page "https://www.gnu.org/software/gpaint/")
(license license:gpl3+)))
-