summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-03-27 11:41:52 -0300
committerVinicius Monego <monego@posteo.net>2024-04-06 08:40:56 -0300
commit0f1e308f3386aad67d2572b0ac8bf94e73e7ed62 (patch)
treed088d8d4452212815ab563c9fca9e868e484e73c /gnu/packages/graphics.scm
parent2d62d08e45eaf1d60841582963c9143a680adef9 (diff)
downloadguix-patches-0f1e308f3386aad67d2572b0ac8bf94e73e7ed62.tar
guix-patches-0f1e308f3386aad67d2572b0ac8bf94e73e7ed62.tar.gz
gnu: opensubdiv: Update to 3.6.0.
* gnu/packages/graphics.scm (opensubdiv): Update to 3.6.0. [arguments]: Use G-Expressions. Remove trailing #t from phases. Change-Id: Ie37f70a5146e5072b362a4439d0669ea19ca2869
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 5d7d169481..5bfd3b2ed2 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1875,7 +1875,7 @@ requirements.")
(define-public opensubdiv
(package
(name "opensubdiv")
- (version "3.4.0")
+ (version "3.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1885,20 +1885,19 @@ requirements.")
(file-name (git-file-name name version))
(sha256
(base32
- "0cippg6aqc5dlya1cmh3908pwssrg52fwgyylnvz5343yrxmgk12"))))
+ "0h9scxiigijzlpv4r0s0nhxlndhv1cmarb2bqgmlwcln1jjvlb4n"))))
(build-system cmake-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'configure 'set-glew-location
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "GLEW_LOCATION" (assoc-ref inputs "glew"))
- #t))
- (add-before 'check 'start-xorg-server
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The test suite requires a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'set-glew-location
+ (lambda _
+ (setenv "GLEW_LOCATION" #$(this-package-input "glew"))))
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The test suite requires a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))))
(native-inputs
(list xorg-server-for-tests))
(inputs