summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-04 22:29:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:26 -0400
commitf85c6ae42116e7aad82fd59804cf52e707f36aca (patch)
tree8376c77815e7847e095562b9e18478141e7ea6d3 /gnu/packages/graphics.scm
parent9fffc12efbe8266a7084d014e2a8d7c4ae00d17e (diff)
downloadguix-patches-f85c6ae42116e7aad82fd59804cf52e707f36aca.tar
guix-patches-f85c6ae42116e7aad82fd59804cf52e707f36aca.tar.gz
gnu: Add python-booleanoperations.
* gnu/packages/graphics.scm (python-booleanoperations): New variable.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9f93205183..b5a81ef196 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -98,6 +98,7 @@
#:use-module (gnu packages pth)
#:use-module (gnu packages pulseaudio) ; libsndfile, libsamplerate
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
@@ -806,6 +807,31 @@ basic geometries.")
;; https://gitlab.com/inkscape/inkscape/issues/784).
(license license:gpl3+)))
+(define-public python-booleanoperations
+ (package
+ (name "python-booleanoperations")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "booleanOperations" version ".zip"))
+ (sha256
+ (base32 "1f41lb19m8azchl1aqz6j5ycbspb8jsf1cnn42hlydxd68f85ylc"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-fonttools python-pyclipper))
+ (native-inputs
+ (list python-defcon-bootstrap
+ python-fontpens-bootstrap
+ python-pytest
+ python-wheel
+ unzip))
+ (home-page "https://github.com/typemytype/booleanOperations")
+ (synopsis "Boolean operations on paths")
+ (description "Boolean operations on paths which uses a super fast
+@url{http://www.angusj.com/delphi/clipper.php, polygon clipper library by
+Angus Johnson}.")
+ (license license:expat)))
+
(define-public pstoedit
(package
(name "pstoedit")