summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-16 15:44:33 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-24 16:23:22 +0200
commit00d1ccaf1275df3b90198f3a4a52aaf9a16cac0e (patch)
treebffcf21fdf046b7939d535d86103c1fd2f499c8f /gnu/packages/graphics.scm
parentbf182596a9d85604f6f029302671a38001575355 (diff)
downloadguix-patches-00d1ccaf1275df3b90198f3a4a52aaf9a16cac0e.tar
guix-patches-00d1ccaf1275df3b90198f3a4a52aaf9a16cac0e.tar.gz
gnu: Use 'search-input-directory' for the OpenEXR header directory.
* gnu/packages/graphics.scm (blender): Use 'search-input-directory' when searching for "include/OpenEXR". (blender-2.79): Likewise. * gnu/packages/image-processing.scm (opencv): Likewise. * gnu/packages/image-viewers.scm (luminance-hdr): Likewise. * gnu/packages/photo.scm (darktable): Likewise.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ca88acf0ec..d794847bc7 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
@@ -556,10 +556,9 @@ typically encountered in feature film production.")
;; in the CPATH, so we need to add "$ilmbase/include/OpenEXR/" to
;; the CPATH to satisfy the dependency on "half.h".
(setenv "CPATH"
- (string-append (assoc-ref inputs "ilmbase")
- "/include/OpenEXR"
- ":" (or (getenv "CPATH") "")))
- #t))))))
+ (string-append
+ (search-input-directory inputs "include/OpenEXR")
+ ":" (or (getenv "CPATH") "")))))))))
(inputs
`(("boost" ,boost)
("jemalloc" ,jemalloc)
@@ -658,10 +657,9 @@ application can be customized via its API for Python scripting.")
;; in the CPATH, so we need to add "$ilmbase/include/OpenEXR/" to
;; the CPATH to satisfy the dependency on "half.h".
(setenv "CPATH"
- (string-append (assoc-ref inputs "ilmbase")
- "/include/OpenEXR"
- ":" (or (getenv "CPATH") "")))
- #t))))))
+ (string-append
+ (search-input-directory inputs "include/OpenEXR")
+ ":" (or (getenv "CPATH") "")))))))))
(inputs
`(("boost" ,boost)
("jemalloc" ,jemalloc)