summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-14 22:12:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-15 00:12:12 +0100
commit79bf16f68830b2ec514e0f7b00c26af3e261c2bb (patch)
tree1f3aee3c41d0ecd4f7aeb0641e28acc861333faf /gnu/packages/graphics.scm
parente23d5aa908cb8864e3efc0c053aad74f995b5965 (diff)
downloadguix-patches-79bf16f68830b2ec514e0f7b00c26af3e261c2bb.tar
guix-patches-79bf16f68830b2ec514e0f7b00c26af3e261c2bb.tar.gz
gnu: ogre: Update to 1.12.9.
The imgui submodule has been removed upstream. * gnu/packages/graphics.scm (ogre): Update to 1.12.9. [source]: Don't clone recursively. [native-inputs]: Add dear-imgui-source. [arguments]: Add an ‘unpack-dear-imgui’ phase. Add IMGUI_DIR to #:configure-flags.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 189ed94a54..3603a7ea77 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -931,23 +931,27 @@ operating system features.")
(define-public ogre
(package
(name "ogre")
- (version "1.12.6")
+ (version "1.12.9")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/OGRECave/ogre")
- (commit (string-append "v" version))
- (recursive? #t))) ;for Dear ImGui submodule
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ap3krrl55hswv1n2r3ijf3xrb3kf9dnqvwyrc0fgnc7j7vd45sk"))))
+ (base32 "0b0pwh31nykrfhka6jqwclfx1pxzhj11vkl91951d63kwr5bbzms"))))
(build-system cmake-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'unpack-dear-imgui
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-recursively (assoc-ref inputs "dear-imgui-source")
+ "../dear-imgui-source")
+ #t))
(add-before 'configure 'pre-configure
- ;; CMakeLists.txt forces CMAKE_INSTALL_RPATH value. As
+ ;; CMakeLists.txt forces a CMAKE_INSTALL_RPATH value. As
;; a consequence, we cannot suggest ours in configure flags. Fix
;; it.
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -961,6 +965,7 @@ operating system features.")
(string-append out "/lib/OGRE"))
";")))
(list (string-append "-DCMAKE_INSTALL_RPATH=" runpath)
+ "-DIMGUI_DIR=../dear-imgui-source"
"-DOGRE_BUILD_DEPENDENCIES=OFF"
"-DOGRE_BUILD_TESTS=TRUE"
"-DOGRE_INSTALL_DOCS=TRUE"
@@ -968,6 +973,7 @@ operating system features.")
"-DOGRE_INSTALL_SAMPLES_SOURCE=TRUE"))))
(native-inputs
`(("boost" ,boost)
+ ("dear-imgui-source" ,(package-source dear-imgui))
("doxygen" ,doxygen)
("googletest" ,googletest-1.8)
("pkg-config" ,pkg-config)))