summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-05 22:56:40 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-06 00:18:30 +0000
commita8448da0f4a090818104e64dd79f90b0e50d5e77 (patch)
tree494c58b4724f12cd9de0db9b0a7096de2b922c0f /gnu/packages/graphics.scm
parent4f4b749e75b38b8c08b4f67ef51c2c8740999e28 (diff)
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar
guix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm42
1 files changed, 41 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7cb4aecec2..7e83c7ea4e 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
+;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,6 +75,7 @@
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages jemalloc)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages maths)
@@ -97,6 +99,7 @@
#:use-module (gnu packages tbb)
#:use-module (gnu packages upnp)
#:use-module (gnu packages video)
+ #:use-module (gnu packages vulkan)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -317,7 +320,7 @@ minimum of resource usage and overhead.")
(synopsis "Interface description language")
(description "Flux is an interface description language used by DirectFB.
Fluxcomp compiles .flux files to .cpp or .c files.")
- (home-page "http://www.directfb.org/")
+ (home-page "https://www.directfb.org/")
(license license:lgpl2.1+))) ; Same as DirectFB
(define-public fox
@@ -1914,3 +1917,40 @@ Some feature highlights:
@item Automatic port forwarding with UPnP
@end itemize\n")
(license license:gpl3+))))
+
+(define-public monado
+ (package
+ (name "monado")
+ (version "21.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.freedesktop.org/" name "/"
+ name "/-/archive/v" version "/"
+ name "-v" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0n04k7a8b0i8ga0kbzh7qxmvni1ijawgk98s83519vxg4d0yyjbq"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("glslang" ,glslang)
+ ("libudev" ,eudev)
+ ("libusb" ,libusb)
+ ("libxcb" ,libxcb)
+ ("libxrandr" ,libxrandr)
+ ("opengl" ,mesa)
+ ("v4l" ,v4l-utils)
+ ("vulkan-loader" ,vulkan-loader)))
+ (native-inputs
+ `(("eigen" ,eigen)
+ ("pkg-config" ,pkg-config)
+ ("vulkan-headers" ,vulkan-headers)))
+ (arguments
+ `(#:configure-flags
+ (list "-Dinstall-active-runtime=false")))
+ (home-page "https://monado.freedesktop.org/")
+ (synopsis "OpenXR runtime")
+ (description "Monado is an OpenXR runtime delivering immersive experiences
+such as VR and AR on mobile, PC/desktop, and any other device. Monado aims to be
+a complete and conforming implementation of the OpenXR API made by Khronos.")
+ (license license:boost1.0)))