summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-02-25 10:35:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-25 10:35:26 +0200
commit0da09b370cc48ac1c090d7a6f5823186534a96d0 (patch)
treeee6affa81139a8f54243e03ea71ab12cc74e7d96 /gnu/packages/graph.scm
parente75335fc91e60ea80dc6bdbe3a99824928820011 (diff)
downloadguix-patches-0da09b370cc48ac1c090d7a6f5823186534a96d0.tar
guix-patches-0da09b370cc48ac1c090d7a6f5823186534a96d0.tar.gz
gnu: python-graph-tool: Limit build to 1 core.
* gnu/packages/graph.scm (python-graph-tool)[arguments]: Set parallel-build to #false. Change-Id: Id181554cda028c6e9985f029a3ef98d14efb0c27
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index fd684ca77d..a3607689a3 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2017-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018, 2020, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2021, 2022, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2020 Alexander Krotov <krotov@iitp.ru>
;;; Copyright © 2020 Pierre Langlois <pierre.langlos@gmx.com>
@@ -833,6 +833,8 @@ transformed into common image formats for display or printing.")
(guix build python-build-system))
#:modules (,@%gnu-build-system-modules
((guix build python-build-system) #:select (site-packages)))
+ ;; The build process peaks around 4GB/RAM per core.
+ #:parallel-build? #f
#:configure-flags
(list (string-append "--with-boost="
(assoc-ref %build-inputs "boost"))